Bug 1002110 - git : insufficient or ancient Obsoletes
git : insufficient or ancient Obsoletes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: git (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Wright
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 09:24 EDT by Michael Schwendt
Modified: 2014-06-10 05:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-10 05:58:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2013-08-28 09:24:56 EDT
An insufficient or ancient Obsoletes tag has been discovered in the
package. It should either be corrected or dropped.

The tag is superfluous, because it doesn't obsolete a package found in
Fedora 16 and newer, and that package is ancient:

    git-0:1.7.7-2.fc16.i686  is oldest
    git <= 0:1.5.4.3  obsoleted by  git-all-0:1.8.3.1-3.fc20.noarch

[semi-automated bug report]
Comment 1 Ondrej Oprala 2014-05-22 09:32:28 EDT
The git specfile contains several lines that are relevant to RHEL only. This is almost certainly one of them.
Comment 2 Michael Schwendt 2014-05-22 11:52:36 EDT
Would you mind making them conditional based on %rhel macro in order to not cause repo metadata bloat for Fedora?

https://fedoraproject.org/wiki/Packaging:DistTag#Conditionals
Comment 3 Ondrej Oprala 2014-06-10 05:58:34 EDT
Sure - fixed in the newest build.

Note You need to log in before you can comment on or make changes to this bug.