Bug 1002117 - quota build 3: mkdir and cp failed on a single brick volume
quota build 3: mkdir and cp failed on a single brick volume
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Raghavendra G
Saurabh
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 09:27 EDT by Saurabh
Modified: 2016-01-19 01:12 EST (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.34rhs
Doc Type: Bug Fix
Doc Text:
Cause: Before creating a file/directory or writing to a file, Quota enforcer requests Quota aggregator for the size of volume to make the decision whether to allow create/write operation. Quota aggregator takes a volume-id and a path and returns the size consumed by that path in the volume represented by volume-id. Because of a string comparison error, sometimes Quota aggregator would pick up a wrong volume and path wouldn't be valid in that volume. Consequence: Since path wouldn't be valid in the (wrong) volume picked up by Quota aggregator, query for size of the volume would fail and as a consequence Quota enforcer would fail writes/creates too. Fix: Make Quota aggregator pick correct volume based on the volume-id provided by Quota enforcer. Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:35:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-08-28 09:27:18 EDT
Description of problem:

mkdir and cp on a volume with single brick, over nfs mount-point

Actually was having a volume with a name "dist1"
and one more volume with similar name "dist"
so as per discussion with developer that may be issue with string comparison

Version-Release number of selected component (if applicable):
glusterfs-fuse-3.4.0.20rhsquota5-1.el6rhs.x86_64
glusterfs-libs-3.4.0.20rhsquota5-1.el6rhs.x86_64
glusterfs-api-3.4.0.20rhsquota5-1.el6rhs.x86_64
glusterfs-geo-replication-3.4.0.20rhsquota5-1.el6rhs.x86_64
glusterfs-server-3.4.0.20rhsquota5-1.el6rhs.x86_64
glusterfs-3.4.0.20rhsquota5-1.el6rhs.x86_64
glusterfs-rdma-3.4.0.20rhsquota5-1.el6rhs.x86_64


How reproducible:
always

Expected results:
this should not be case, each volume should be considered a separate entity.

Additional info:
Comment 2 Raghavendra G 2013-08-29 12:37:08 EDT
Patch can be found at https://code.engineering.redhat.com/gerrit/12135
Comment 3 Saurabh 2013-10-22 02:32:50 EDT
working on glusterfs-3.4.0.35rhs
Comment 4 errata-xmlrpc 2013-11-27 10:35:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.