Bug 1002189 - qemu-sanity-check doesn't work with kernel-debug kernels
qemu-sanity-check doesn't work with kernel-debug kernels
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qemu-sanity-check (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 999518
  Show dependency treegraph
 
Reported: 2013-08-28 11:17 EDT by Richard W.M. Jones
Modified: 2013-09-30 21:53 EDT (History)
1 user (show)

See Also:
Fixed In Version: qemu-sanity-check-1.1.4-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 11:34:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2013-08-28 11:17:21 EDT
Description of problem:

kernel-debug kernels have debugging information, but are
otherwise regular kernels.  qemu-sanity-check cannot use
these kernels because they have names like:

/boot/vmlinuz-3.11.0-0.rc7.git0.1.fc21.x86_64+debug

whereas qemu-sanity-check searches for kernels using this
wildcard:

/boot/vmlinuz-*.$arch

Although it's possible to work around this by using an
explicit --kernel parameter, it'd be nice if +debug
kernel were recognized.

Version-Release number of selected component (if applicable):

qemu-sanity-check 1.1.3

Additional info:

https://bugzilla.redhat.com/show_bug.cgi?id=999518#c6
Comment 1 Richard W.M. Jones 2013-08-28 11:34:51 EDT
Fixed in 1.1.4.

http://koji.fedoraproject.org/koji/taskinfo?taskID=5865333
Comment 2 Fedora Update System 2013-08-28 12:15:58 EDT
qemu-sanity-check-1.1.4-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/qemu-sanity-check-1.1.4-2.fc19
Comment 3 Fedora Update System 2013-09-30 21:53:40 EDT
qemu-sanity-check-1.1.4-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.