Bug 1002197 - blender.spec suggested enhancements: localization, plus jemalloc and OpenColorIO support
Summary: blender.spec suggested enhancements: localization, plus jemalloc and OpenColo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: blender
Version: rawhide
Hardware: All
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Jochen Schmitt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-08-28 15:26 UTC by François Cami
Modified: 2013-11-10 06:42 UTC (History)
5 users (show)

Fixed In Version: blender-2.68a-5.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-14 02:31:51 UTC


Attachments (Terms of Use)
The screenshot of 2.68a-4 with "interface" translation checked. (45.04 KB, image/png)
2013-09-03 04:19 UTC, Cheng-Chia Tseng
no flags Details
This is the output file that I changed the language from English to Chinese (Traditional) in this session. (2.49 MB, text/plain)
2013-09-03 14:40 UTC, Cheng-Chia Tseng
no flags Details

Description François Cami 2013-08-28 15:26:16 UTC
Description of problem:

The current blender.spec does not enable jemalloc support.
See http://www.sintel.org/development/memory-jemalloc/ for the benefits this brings, namely less RAM usage, better cache usage, etc.

Ditto for OpenColorIO. See http://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.64/Color_Management for details.

Last but not least, the files needed to localize (display in another language than English) the interface are rm'd post-install, leading to bug reports like bz #867285.

Updated SPEC: http://fcami.fedorapeople.org/srpms/blender.spec
Updated SRPM: http://fcami.fedorapeople.org/srpms/blender-2.68a-3.fc18.src.rpm


Version-Release number of selected component (if applicable):

blender-2.68a-1.fc18
blender-2.68a-2.fc20

Comment 1 Fedora Update System 2013-08-28 21:38:47 UTC
blender-2.68a-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/blender-2.68a-3.fc19

Comment 2 Fedora Update System 2013-08-28 21:40:31 UTC
blender-2.68a-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/blender-2.68a-3.fc18

Comment 3 Fedora Update System 2013-08-29 22:19:02 UTC
Package blender-2.68a-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing blender-2.68a-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15478/blender-2.68a-3.fc18
then log in and leave karma (feedback).

Comment 4 Cheng-Chia Tseng 2013-08-30 11:02:04 UTC
I found out that i18n feature work with the testing package. 

There is a small defect that after I checked "International Fonts" the diplaying font suddenly chaged (to a font I don't know, but it did not look like as the same as the one provided by official blender). In the popout menu, only the local name of Hindi lanuguage does not present normally. And the window is not wide enough to diplay all the content, I have to widen the window to see them all.

I tried to find out what happened during the checking. Opening blender via terminal, I find out that it prints out "Warning: Can't find default font!" as I check the box. After saving the preference and reopen blender via terminal, it keeps printing out "Warning: Can't find default font!"

I tested official release of blender, and found that there was no such warning printed issue. 

However, I have to say that blender works absoloutely better than before! I can launch blender in my language now! :) Thanks for your hard work!

Comment 5 François Cami 2013-08-31 21:19:27 UTC
@Cheng-Chia

Could you please tell us which language you use?  The output of
echo $LANG
on your system might be useful as well.
Thank you.

Comment 6 Cheng-Chia Tseng 2013-09-01 05:45:35 UTC
my echo $LANG prints "zh_TW.UTF-8"

Comment 7 Jochen Schmitt 2013-09-01 09:07:35 UTC
@Cheng-chia

Can you check, if you have installed the fonts-blender package? The issue is,
that this package contains a special font file which i a merge of several
fonts required for internetionalization support.

Comment 8 Jochen Schmitt 2013-09-01 13:34:07 UTC
UNfortunately, I have find an issue with your suggestion package. The issue is,
that the blender package nows contains the locale file twice in /usr/share/blender/2.68/datafiles/locale
and in /usr/share/locale. So I now try to a solution for this issue. From my mind
a rework of the blender-2.67-syspath.patch is required.

Comment 9 Cheng-Chia Tseng 2013-09-01 14:44:15 UTC
(In reply to Jochen Schmitt from comment #7)
> @Cheng-chia
> 
> Can you check, if you have installed the fonts-blender package? The issue is,
> that this package contains a special font file which i a merge of several
> fonts required for internetionalization support.

I checked with 'rpm -q fonts-blender' command. It said that I have installed " fonts-blender-2.68a-3.fc19.noarch."

Comment 10 Jochen Schmitt 2013-09-01 15:59:06 UTC
Thank you for your answer. I was able to reproduced your waning message about the
default font and have make a strace on blender to find out the reason for this issue.
The reason is, that the font name droidsans.ttf.gz must be changed to DroidSans.ttf,
if you want to use the DroidSans system font of Fedora.
So I now try to create a package which should fix this issue and avoid the
twice occurance of the locale files.

Comment 11 Jochen Schmitt 2013-09-01 21:21:03 UTC
I have created an updated package blender-2.68a-4 which should not display the warning message about the default font. It may be nice, if anyone can try out this package.

Comment 12 Fedora Update System 2013-09-02 23:26:18 UTC
Package blender-2.68a-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing blender-2.68a-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15478/blender-2.68a-4.fc18
then log in and leave karma (feedback).

Comment 13 Cheng-Chia Tseng 2013-09-03 04:18:22 UTC
Well, I have just tested 2.68a-4. 

The international fonts feature just reverted back to the situation as it was - all non-English characters are displayed as squares.

Comment 14 Cheng-Chia Tseng 2013-09-03 04:19:42 UTC
Created attachment 793008 [details]
The screenshot of 2.68a-4 with "interface" translation checked.

Comment 15 Jochen Schmitt 2013-09-03 14:33:48 UTC
I'm sorry to hear this. Unfortunately, I could not reproduced this case.
So it may be helpful, if you can do a 
$ strace -o output.txt blender
and provide me the content of the file output.txt which will be produced
during the test run.

Comment 16 Cheng-Chia Tseng 2013-09-03 14:40:04 UTC
Created attachment 793228 [details]
This is the output file that I changed the language from English to Chinese (Traditional) in this session.

Comment 17 Jochen Schmitt 2013-09-03 16:23:29 UTC
Thank you for your quick response. I could not found an obviouses error in the
output.txt file. I have done a closer look on your screenshoot and don't understand,
why you have an issue. Please keep in my, that I don't have any expirience witch
chinesse fonts. So it may be nice, if you can explain be in detailed what 
is your issue. On my own system I could not find out a malfuction in the
dialogue for the internetional font feature.

Comment 18 Cheng-Chia Tseng 2013-09-03 16:48:22 UTC
That's strange because blender-2.68a-3 works well with diplaying almost those non-western characters except Hindi. It seems that system could pick another font automatically to display those characters with 2.68a-3 on my f19.

However, it works fine on your machine. That is strange too. :S

Maybe providing "Droid Sans Fallback" instead of "Droid Sans" could help display those non-western characters?

Comment 19 Cheng-Chia Tseng 2013-09-03 16:50:32 UTC
Or should we use the fonts that blender officially provided directly, should that work?

Comment 20 Cheng-Chia Tseng 2013-09-03 17:37:53 UTC
I figured out that blender use "Blender Mono I18n" or "bmonofont-i18n" to display those non-western characters.

I think that there might be something wrong with that in 2.68a-4?

Comment 21 Jochen Schmitt 2013-09-03 18:27:44 UTC
One diffent between blender-2.68a-3 and blender-2.68a-4 is, that the last could
find the DroidSans.ttf font providing from Fedora in opposite of the first one.
So, if you have a issue with wrong displayed characters, this may be an issue
with the DroidSans font. But unfortunately, I'm not a specialist for eastern-asiatic
font.

Comment 22 Cheng-Chia Tseng 2013-09-03 19:06:29 UTC
I found out that the Droid Sans (droidsans_final_fixed) provided by official blender is about 5.6MB which contains CJK characters. The size is even larger than Droid Sans Fallback (which is the CJK variant of Droid Sans) of 5.4MB.

I guess that system just pick Droid Sans provided by fedora (702KB) which contains no CJK characters and does not fallback (it should be automatically done by fontconfig mechanism) to other fonts in my system.

Comment 23 Jochen Schmitt 2013-09-03 20:55:47 UTC
you told be, that the Fedora DroidSans.ttf file doesn't contains CJK glyphs in opposite
of the droidsans.ttf.gz file provided by the original blender distribution.
So I want to ask you, if you may able to open a bug report agains google-droid-sans-fonts
for asking to CJK support and set a blocker to this bug report.
It maybe better, that you open the bug report, because you have more expirence
for CJK glyphs in opposite of myselft.
For information, the Fedor blender package load the font /usr/share/fonts/google-droide/DroidSans.ttf
directly with the use of fontconfig or other font managment facilities.

Comment 24 Cheng-Chia Tseng 2013-09-04 05:21:03 UTC
I think that ask Droid fonts of fedora to add CJK support is impossible, because the work by official blender is a derived work from Droid Sans and DejaVu Sans.

Droid Sans Fallback is an upstream CJK font from Droid font project and it is separate from Droid Sans. There are many upstream Droid Sans XXXX fonts which serve different non-Western languages.

The work from blender seems to be a combination of DejaVu Sans and Droid Sans Fallback. You can see that its font family name is called as "DejaVu Sans" "Book style" while the name of the file is called as "droidsans_final_fixed."

It is better to provide the font in the way of official blender provides because that is a derived work and cannot be pushed or changed in those fedora Droid Sans or DejaVu Sans packages.

Comment 25 Jochen Schmitt 2013-09-04 17:55:31 UTC
Ok, I have decide to include droidesans.ttf.gz into the fonts-blender subpackage.

So it may be nice, if anyone can tryout the blender-2.68a-5 package.

Comment 26 Fedora Update System 2013-09-06 04:00:54 UTC
Package blender-2.68a-5.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing blender-2.68a-5.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15478/blender-2.68a-5.fc18
then log in and leave karma (feedback).

Comment 27 Cheng-Chia Tseng 2013-09-09 04:21:14 UTC
Now the international feature (including Hindi) looks good. 
I think that it 2.68a-5 is in good shape! :)

Comment 28 Fedora Update System 2013-09-14 02:31:51 UTC
blender-2.68a-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 29 Fedora Update System 2013-09-14 02:38:13 UTC
blender-2.68a-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 30 Cheng-Chia Tseng 2013-10-30 04:57:58 UTC
I am testing fedora 20 Beta, and find that blender package in f20 is "blender-2.68a-4.fc20.x86_64".

So the international font problem still exist in f20. Will f20 receive blender-2.68a-5.fc20 update?

Comment 31 Fedora Update System 2013-10-30 09:12:59 UTC
blender-2.68a-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/blender-2.68a-5.fc20

Comment 32 François Cami 2013-10-30 09:14:10 UTC
It looks like we forgot to push for f20 :)
Thanks a lot for your help.

Comment 33 Fedora Update System 2013-11-10 06:42:28 UTC
blender-2.68a-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.