Bug 1002209 - semanage fcontext provides wrong SELinux local fcontext equivalence when directory provided has a trailing /
semanage fcontext provides wrong SELinux local fcontext equivalence when dire...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: policycoreutils (Show other bugs)
6.4
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Miroslav Grepl
Eduard Benes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 11:45 EDT by rlopez
Modified: 2014-10-14 04:04 EDT (History)
5 users (show)

See Also:
Fixed In Version: policycoreutils-2.0.83-19.41.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 04:04:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rlopez 2013-08-28 11:45:48 EDT
Description of problem:
I'm currently trying to set the SELinux local fcontext Equivalence of my directory /u01 to be the same as /usr. 

Version-Release number of selected component (if applicable):
policycoreutils-python-2.0.83-19.30.el6.x86_64

How reproducible:
100% of the time

Steps to Reproduce:
1. semanage fcontext -a -e /usr /u01/
2.restorecon -R -v /u01/


Actual results:
Produces type default_t

Expected results:
type usr_t

Additional info:
If one were to remove the trailing / in the original step 1 as follows:
semanage fcontext -a -e /usr/ /u01, followed by a restorecon -R -v /u01/ it would provide the correct labeling.
Comment 3 RHEL Product and Program Management 2014-03-25 20:18:00 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 7 errata-xmlrpc 2014-10-14 04:04:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1569.html

Note You need to log in before you can comment on or make changes to this bug.