Bug 1002223 - No splash screen shown on launch of Myrtle
No splash screen shown on launch of Myrtle
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: snifflib (Show other bugs)
19
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
: EasyFix, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 12:22 EDT by mray271
Modified: 2013-10-02 03:30 EDT (History)
6 users (show)

See Also:
Fixed In Version: 1.9.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 03:30:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch to /usr/bin/myrtle (435 bytes, text/plain)
2013-08-28 12:22 EDT, mray271
no flags Details

  None (edit)
Description mray271 2013-08-28 12:22:41 EDT
Created attachment 791459 [details]
Proposed patch to /usr/bin/myrtle

Description of problem:

Launching Myrtle spreadsheet by /usr/bin/myrtle script should produce splash image.

Version-Release number of selected component (if applicable):

1.8.12-1.fc19.noarch

currently available from the fedora-updates-testing repository

How reproducible:

Always

Steps to Reproduce:
1. yum install myrtle
2. myrtle
3.

Actual results:

Spreadsheet application opens as intended, but no splash shown.

Expected results:

Splash image should be shown briefly prior to application launch.

Additional info:
The splash image is a resource in in snifflib.jar (/usr/share/java/snifflib.jar) and has path
com/mockturtlesolutions/snifflib/spreadsheets/images/myrtlesplash.png

See attached patch.
Comment 1 Mikolaj Izdebski 2013-08-29 07:12:45 EDT
Fixed in snifflib-1.8.13-1
Comment 2 Mikolaj Izdebski 2013-08-29 07:14:11 EDT
Fixed in snifflib-1.8.13-2
Comment 3 Fedora Update System 2013-09-03 13:25:04 EDT
snifflib-1.8.13-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/snifflib-1.8.13-2.fc19
Comment 4 Mikolaj Izdebski 2013-09-10 05:19:25 EDT
Fixed in snifflib-1.9.0-2
Comment 5 Fedora Update System 2013-09-19 09:43:28 EDT
snifflib-1.9.0-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/snifflib-1.9.0-2.fc20
Comment 6 Fedora Update System 2013-09-19 09:44:24 EDT
snifflib-1.9.0-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/snifflib-1.9.0-2.fc19
Comment 7 Fedora Update System 2013-09-22 20:39:38 EDT
snifflib-1.9.0-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-10-02 02:52:41 EDT
snifflib-1.9.0-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Mikolaj Izdebski 2013-10-02 03:30:14 EDT
I believe that this bug is fixed in snifflib-1.9.0-2,
which is available in updates for Fedora 19, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=463390

Note You need to log in before you can comment on or make changes to this bug.