Bug 1002243 - [abrt] yum-utils-1.1.31-10.fc18: sqlitesack.py:233:_sql_MD:KeyError: <yum.yumRepo.YumRepository object at 0x2421190>
[abrt] yum-utils-1.1.31-10.fc18: sqlitesack.py:233:_sql_MD:KeyError: <yum.yum...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:12aff324f378b3d5435f0b1dfee...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 13:23 EDT by Suawomirr
Modified: 2013-08-29 03:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 03:33:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.08 KB, text/plain)
2013-08-28 13:23 EDT, Suawomirr
no flags Details
File: dso_list (63 bytes, text/plain)
2013-08-28 13:23 EDT, Suawomirr
no flags Details
File: environ (3.19 KB, text/plain)
2013-08-28 13:23 EDT, Suawomirr
no flags Details

  None (edit)
Description Suawomirr 2013-08-28 13:23:00 EDT
Description of problem:
I was trying to download the kernel srpm with the command:
yumdownloader --downloadonly --source kernel

Version-Release number of selected component:
yum-utils-1.1.31-10.fc18

Additional info:
reporter:       libreport-2.1.6
cmdline:        /usr/bin/python /usr/bin/yumdownloader --downloadonly --source kernel
executable:     /usr/bin/yumdownloader
kernel:         3.10.9-100.fc18.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
sqlitesack.py:233:_sql_MD:KeyError: <yum.yumRepo.YumRepository object at 0x2421190>

Traceback (most recent call last):
  File "/usr/bin/yumdownloader", line 273, in <module>
    util = YumDownloader()
  File "/usr/bin/yumdownloader", line 73, in __init__
    self.main()
  File "/usr/bin/yumdownloader", line 98, in main
    self.exit_code = self.downloadPackages(opts)
  File "/usr/bin/yumdownloader", line 213, in downloadPackages
    probs = self.downloadPkgs(toDownload)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2333, in downloadPkgs
    urlgrabber.grabber.parallel_wait()
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 2259, in parallel_wait
    perform()
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 2198, in perform
    try: _run_callback(opts.checkfunc, opts)
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1010, in _run_callback
    return cb(obj)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2300, in checkfunc
    self.verifyPkg(obj, po, 1)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2127, in verifyPkg
    if not po.verifyLocalPkg():
  File "/usr/lib/python2.7/site-packages/yum/packages.py", line 978, in verifyLocalPkg
    (csum_type, csum) = self.returnIdSum()
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 347, in returnIdSum
    return (self.checksum_type, self.pkgId)
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 266, in __getattr__
    (self.pkgId,)).fetchone()
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 46, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 233, in _sql_MD
    cache = getattr(self.sack, MD + 'db')[self.repo]
KeyError: <yum.yumRepo.YumRepository object at 0x2421190>

Local variables in innermost frame:
MD: 'primary'
self: <YumAvailablePackageSqlite : kernel-3.10.9-100.fc18.src (0x26dba90)>
args: (('612c6f1045aac0de80fc905ff885f202f528c7d5ec7534cb26b5cf287c94968a',),)
sql: 'SELECT checksum_type FROM packages WHERE pkgId = ?'
Comment 1 Suawomirr 2013-08-28 13:23:05 EDT
Created attachment 791480 [details]
File: backtrace
Comment 2 Suawomirr 2013-08-28 13:23:13 EDT
Created attachment 791481 [details]
File: dso_list
Comment 3 Suawomirr 2013-08-28 13:23:17 EDT
Created attachment 791482 [details]
File: environ
Comment 4 Zdeněk Pavlas 2013-08-29 03:33:44 EDT
--downloadonly does not make much sense with yumdownloader (we always "only" download), but obviously it should not fail..  This is a dupe do BZ 973380, already fixed in fc19.  I don't think it's worth backporting.

Note You need to log in before you can comment on or make changes to this bug.