Bug 1002260 - server fails to start after upgrade(schema error)
Summary: server fails to start after upgrade(schema error)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base
Version: 6.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Rich Megginson
QA Contact: Sankar Ramalingam
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-08-28 18:32 UTC by Noriko Hosoi
Modified: 2013-11-21 21:11 UTC (History)
2 users (show)

Fixed In Version: 389-ds-base-1.2.11.15-23.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 21:11:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1653 normal SHIPPED_LIVE 389-ds-base bug fix update 2013-11-20 21:53:19 UTC

Description Noriko Hosoi 2013-08-28 18:32:57 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/47318

389-ds-base-1.3.0.5-1.20130404T0401zgit8f86104.fc18.x86_64

I was trying to set up replication for IPA between 6.3 and F-18 which was running a pre-release of 1.3.1 from daily repo. The replication succeeded but the resulting server would not start with the error:

08/Apr/2013:16:55:05 -0400] - Entry "cn=RootDN Access Control,cn=plugins,cn=config" -- attribute "nsslapd-plugin-depends-on-type" not allowed

I downgraded the packages and the installation was fine.

I can't be sure if this is related or not, but when the 6.3 server failed to install I tried a 6.4 instance. Upon restarting dirsrv in 6.4 I see this on stdout:

[08/Apr/2013:17:07:46 -0400] attr_syntax_create - Error: the EQUALITY matching rule [caseIgnoreIA5Match] is not compatible with the syntax [1.3.6.1.4.1.1466.115.121.1.15] for the attribute [dc]
[08/Apr/2013:17:07:46 -0400] attr_syntax_create - Error: the SUBSTR matching rule [caseIgnoreIA5SubstringsMatch] is not compatible with the syntax [1.3.6.1.4.1.1466.115.121.1.15] for the attribute [dc]

Comment 1 Noriko Hosoi 2013-08-28 18:40:52 UTC
Mark Reynolds wrote:
> To reproduce this, install 1.2.10, and upgrade to "6.5". If the server
> fails to start then the bug is still there.

Comment 2 Nathan Kinder 2013-08-28 18:50:04 UTC
Specifically, this can be verified by attempting to update from the 389-ds-base-1.2.10 packages from RHEL 6.3 to the 389-ds-base 1.2.11 packages from RHEL 6.5.  If the server starts up fine, the fix is verified.

Comment 4 Sankar Ramalingam 2013-10-03 15:57:43 UTC
Successfully verified by upgrading from RHEL6.3 to RHEL6.5. server instances started successfully without any issues. Hence, marking the bug as Verified.

Comment 5 errata-xmlrpc 2013-11-21 21:11:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1653.html


Note You need to log in before you can comment on or make changes to this bug.