Bug 1002295 - ypbind should not depend on NetworkManager-wait-online
ypbind should not depend on NetworkManager-wait-online
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ypbind (Show other bugs)
rawhide
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 16:19 EDT by Elliott Forney
Modified: 2013-08-30 06:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: ypbind-1.37.1-7.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-30 06:34:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elliott Forney 2013-08-28 16:19:22 EDT
Description of problem:

ypbind currently depends on NetworkManager-wait-online.  This causes a dependency failed warning from systemd during boot when using the plain network service instead of NetworkManager.

ypbind should only depend on network.target in F20.  I am told that network.target will now wait for NetworkManager-wait-online if NetworkManager is enabled.

See bug 921774
Comment 1 Honza Horak 2013-08-29 06:14:39 EDT
Thanks for reporting, I will fix it.
Comment 2 Honza Horak 2013-08-29 06:34:10 EDT
Actually it turned to be not so clear what caused the problem. See my comment in https://bugzilla.redhat.com/show_bug.cgi?id=921774#c3

Not that I'd have problem with removing After=NetworkManager-wait-online.service from the unit file, since it shouldn't be needed, but I'd rather find out the real cause of the problem first.
Comment 3 Dan Winship 2013-08-29 08:07:40 EDT
copying from the other bug:

I got it wrong before; you should replace NetworkManager-wait-online.service with network-online.target. That's the new abstracted target (in systemd >= 200), which is equivalent to NetworkManager-wait-online target when NM is active, but might make use of some other service in spins/distros that don't use NM.

(In reply to Honza Horak from comment #2)
> Not that I'd have problem with removing
> After=NetworkManager-wait-online.service from the unit file, since it
> shouldn't be needed, but I'd rather find out the real cause of the problem
> first.

Yeah, I don't know the details of systemd dependencies and error messages. It's possible you shouldn't *need* to remove it, but you definitely can remove it.
Comment 4 Honza Horak 2013-08-29 09:42:22 EDT
Thanks for making it clear. From what I understand from systemd.special(7) network-online.target is part of systemd and *don't have to be enabled* at all (if not required by other services).

On the other hand, NetworkManager-wait-online.service is part of NetworkManager and can be enabled even if network-online.target is not. Because of this reason I'd like to include both in After=, which should ensure proper ordering in case any of them is enabled.

Note You need to log in before you can comment on or make changes to this bug.