Bug 1002300 - UpdateVmDevice doesn't update the network bandwidth of the vnic
UpdateVmDevice doesn't update the network bandwidth of the vnic
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity medium
: ---
: 3.3.0
Assigned To: Dan Kenigsberg
Martin Pavlik
network
:
Depends On: 1014198
Blocks: 3.3snap1
  Show dependency treegraph
 
Reported: 2013-08-28 16:34 EDT by Moti Asayag
Modified: 2016-02-10 14:55 EST (History)
9 users (show)

See Also:
Fixed In Version: is20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:14:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
downstream-only patch that fixed the issue. (4.89 KB, patch)
2013-10-23 07:36 EDT, Eyal Edri
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19545 None None None Never

  None (edit)
Description Moti Asayag 2013-08-28 16:34:42 EDT
Description of problem:
When vdsm receives a requestion for updating a vnic device (either on the same network or by rewiring the nic to a new network)

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. From ovirt-engine webadmin, edit vm network interface and replaces its current profile to other profile which has different network qos settings (either vnic profile on the same network or on other network)

Actual results:
The previous network qos definition remains for the vnic

Expected results:
The network qos of the vnic should be updated accordingly to the new configuration.

Additional info:
Here is a part of the vdsm.log which shows the received parameters aren't being used for creating the libvirt dom element of the vnic device:

Thread-4299::DEBUG::2013-08-28 18:46:42,161::BindingXMLRPC::974::vds::(wrapper) client [10.35.7.221]::call vmUpdateDevice with ('1170b2f9-6046-4d03-ab46-9e39e0606706', {'linkActive': 'true'
, 'network': 'vlan100', 'specParams': {'inbound': {'average': '128', 'peak': '128', 'burst': '1024'}, 'outbound': {'average': '128', 'peak': '128', 'burst': '1024'}}, 'custom': {}, 'alias':
 'net0', 'deviceType': 'interface'}) {}
Thread-4299::DEBUG::2013-08-28 18:46:42,207::vm::3098::vm.Vm::(setLinkAndNetwork) vmId=`1170b2f9-6046-4d03-ab46-9e39e0606706`::Nic has been updated:
 <interface type="bridge">
        <address bus="0x00" domain="0x0000" function="0x0" slot="0x03" type="pci"/>
        <mac address="00:1a:4a:c2:64:7c"/>
        <model type="e1000"/>
        <source bridge="vlan100"/>
        <filterref filter="vdsm-no-mac-spoofing"/>
        <link state="up"/>
        <bandwidth>
                <inbound average="128000" burst="102400" peak="128000"/>
                <outbound average="1280" burst="102400" peak="1280"/>
        </bandwidth>
</interface>
Comment 2 Dan Kenigsberg 2013-09-15 18:01:43 EDT
vm.Vm.setLinkAndNetwork() creates a devxml from the device's old conf, patching it up with changed bits and pieces[*], and then passes it to libvirt. If libvirt-side updated has succeeded, the device and its conf are updated in vdsm memory.

Essentially, the stage marked by [*] above is a partial re-write of dev.getXML, that misses changes to QoS.
Comment 3 Eyal Edri 2013-10-23 07:36:36 EDT
Created attachment 815340 [details]
downstream-only patch that fixed the issue.
Comment 5 Martin Pavlik 2013-10-29 06:53:10 EDT
works in is20, change in QoS is applied properly on running VM
Comment 7 Charlie 2013-11-27 19:27:13 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 8 Dan Kenigsberg 2013-12-02 12:38:00 EST
This bug has popped during the devel cycle for rhev-3.3. No need to document separately from the vNIC QoS feature (aka vNIC profiles).
Comment 9 errata-xmlrpc 2014-01-21 11:14:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.