Bug 1002325 - [RFE] Automatic enablement of SSH daemon
[RFE] Automatic enablement of SSH daemon
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 4.0
Assigned To: Martin Magr
Nir Magnezi
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 18:06 EDT by Tadej Janež
Modified: 2013-09-18 10:16 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 10:16:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tadej Janež 2013-08-28 18:06:49 EDT
Description of problem:
I've used the Desktop Live CD to install Fedora 19.
Then I've used the instructions provided at:
https://fedoraproject.org/wiki/Test_Day:2013-04-02_OpenStack#Install_and_setup_all_Openstack_services_on_a_single_node
to prepare the system and run packstack.

Packstack failed because the SSH daemon wasn't running (which is apparently the default for a Desktop Live CD install).

It would be great if packstack detected this and executed the following:
systemctl enable sshd.service
systemctl start sshd.service


Version-Release number of selected component (if applicable):
openstack-packstack-2013.1.1-0.28.dev677.fc19.noarch
Comment 2 Martin Magr 2013-09-18 10:16:41 EDT
For this you would need to run Packstack as root, which is what we want to avoid.

Also the proposed fix would help only in one case, which is all-in-one installation and only if you would run packstack on host where you want to install OpenStack.

Packstack should just failed with appropriate message that selected host(s) are not SSH available. This works in all cases.

Note You need to log in before you can comment on or make changes to this bug.