Bug 1002326 - [RFE] Augment the final script output with instructions on how to obtain the Dashboard user name and password
[RFE] Augment the final script output with instructions on how to obtain the ...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 4.0
Assigned To: Ivan Chavero
Martin Magr
: FutureFeature, OtherQA
Depends On:
Blocks: RHOS40RFE
  Show dependency treegraph
 
Reported: 2013-08-28 18:15 EDT by Tadej Janež
Modified: 2014-02-13 22:59 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:22:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 59246 None None None Never

  None (edit)
Description Tadej Janež 2013-08-28 18:15:43 EDT
Description of problem:
When installing OpenStack via packstack, the user is given the following output at the end:
" **** Installation completed successfully ******


Additional information:
 * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.
 * Did not create a cinder volume group, one already existed
 * To use the command line tools you need to source the file /root/keystonerc_admin created on 192.168.122.181
 * To use the console, browse to http://192.168.122.181/dashboard
 * The installation log file is available at: /var/tmp/packstack/20130828-235142-dd7cAf/openstack-setup.log"

It would be great if, in addition to pointing the user to http://192.168.122.181/dashboard, it would say:
"(user name and password are the values of OS_USERNAME and OS_PASSWORD variables in file /root/keystonerc_admin)".


Version-Release number of selected component (if applicable):
openstack-packstack-2013.1.1-0.28.dev677.fc19.noarch
Comment 2 Tadej Janež 2013-09-07 11:04:51 EDT
I've submitted a patch for this to gerrit:
https://review.openstack.org/45534
Comment 3 Ivan Chavero 2013-11-29 19:31:18 EST
Added message on location of the file containing username and password.
Comment 4 Alvaro Lopez Ortega 2013-11-30 05:08:23 EST
It'd reword the message to something like this:

=================
To access the OpenStack Dashboard browse to %s://%s/dashboard

Please, find your login credentials stored in the keystonerc_admin in
your home directory.
=================
Comment 5 Ivan Chavero 2013-11-30 16:29:13 EST
Changes added to the patch
Comment 6 Alvaro Lopez Ortega 2013-12-01 05:06:41 EST
Merged
Comment 9 Martin Magr 2013-12-12 10:51:15 EST
Additional information:
 * Did not create a cinder volume group, one already existed
 * File /root/keystonerc_admin has been created on OpenStack client host 192.168.122.15. To use the command line tools you need to source the file.
 * Copy of keystonerc_admin file has been created for non-root user in /home/para.
 * To access the OpenStack Dashboard browse to http://192.168.122.15/dashboard.
Please, find your login credentials stored in the keystonerc_admin in your home directory.
 * To use Nagios, browse to http://192.168.122.15/nagios username : nagiosadmin, password : 152aa355fbfd4009
Comment 10 Scott Lewis 2013-12-13 09:41:27 EST
Adding FutureFeatures to RHOS 4 feature tracker
Comment 12 errata-xmlrpc 2013-12-19 19:22:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.