Bug 1002334 - Provide a simpler, cached alternative to getReleaseComponents
Provide a simpler, cached alternative to getReleaseComponents
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: WebService (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 18:59 EDT by Jon Orris
Modified: 2013-08-28 19:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 19:24:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Orris 2013-08-28 18:59:54 EDT
Description of problem:
The errata system has to call the xmlrpc method getReleaseComponents repeatedly to ensure it is up to date. This is inefficient for both the errata system and bugzilla; changes are intermittent, yet users are upset if there is any delay so we must query constantly.

If we could provide this data in a simpler format, JSON or text, with Apache setting and handling Last-Modified and If-Modified-Since headers, that'd be a major improvement.
Comment 1 Simon Green 2013-08-28 19:24:46 EDT
(In reply to Jon Orris from comment #0)
> If we could provide this data in a simpler format, JSON or text,

You can use JSONRPC to get the results back in JSON format. This is faster than using XMLRPC since it doesn't need to type the returned data.

> with Apache
> setting and handling Last-Modified and If-Modified-Since headers, that'd be
> a major improvement.

This is something that we considered doing as part of the performance upgrade but decided against it. There are four major reasons:

(1) This would be a customisation we would need to support.
(2) Not everyone has the same view of releases, and therefore we would need to do a complete database query to get the last modified value
(3) If the data has modified, then we need to get the data twice.
(4) There is a disjoint between the Bugzilla web servers, proxy servers and load balancers.

Note You need to log in before you can comment on or make changes to this bug.