Bug 1002336 - Ensure nss requires the approriate version of nss-softokn
Ensure nss requires the approriate version of nss-softokn
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nss (Show other bugs)
6.6
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Elio Maldonado Batiz
Hubert Kario
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 19:17 EDT by Elio Maldonado Batiz
Modified: 2014-10-14 01:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 01:02:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1378 normal SHIPPED_LIVE nss bugfix and enhancement update 2014-10-13 21:06:09 EDT

  None (edit)
Description Elio Maldonado Batiz 2013-08-28 19:17:13 EDT
Description of problem: The version of nss-softoken that nss must require is the last one that received FIPS 140 validation or in some cases the one being prepared for submission for validation.  

Bug 962465 reported the case where nss was built against and incorrect version of nss-softoken and the ensuing problems.

Version-Release number of selected component (if applicable):

How reproducible: Once

Steps to Reproduce:  From Bug 962465
1. rebuild nss against new nss-softokn
2. install the packages on a system with old nss-softokn
3. curl -svo/dev/null https://google.com

Actual results:
curl does not work

Expected results:
curl should work.


Additional info:

Either updating nss-softokn or rebuilding nss against the old one fixes the problem. By the old is meant nss-softoken-3.12.9 which was the last version to be FIPS validated. By the new one I assume is the one being worked on for the sumbmition but I am not sure. 

The investigation as to the causes should be completed and the the necessary modification to the nss.spec made to ensure we build with the correct version of nss-softoken. If the incorrect version is the one tagged into the buildroot override the brew should fail.
Comment 2 Elio Maldonado Batiz 2013-08-28 19:40:54 EDT
From Bob Relyea's email where he requsted I enter this bug:

>BTW Elio, see comment 16 in the bug.  It suggests you open a bug to
>investigate why there was a problem with the mismatched softokens. That
>bug should not be targetted for RHEL-6.5. 
            ^^^
>Then tell QE that they can verify this bug by inspection of the nss.spec file.
Comment 13 errata-xmlrpc 2014-10-14 01:02:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1378.html

Note You need to log in before you can comment on or make changes to this bug.