Bug 1002346 - Spring Framework on JBoss EAP6 QuickStart fails [NEEDINFO]
Spring Framework on JBoss EAP6 QuickStart fails
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Templates (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Andy Grimm
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 20:25 EDT by Diane Mueller
Modified: 2016-11-07 22:47 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-11 17:26:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
agrimm: needinfo? (dmueller2001)


Attachments (Terms of Use)
screenshot of default values (71.81 KB, image/png)
2013-08-29 10:46 EDT, Diane Mueller
no flags Details
here is the screenshot with the error message (again) (49.57 KB, image/png)
2013-08-29 10:47 EDT, Diane Mueller
no flags Details
attempt to open url in browser results (40.38 KB, image/png)
2013-08-29 10:49 EDT, Diane Mueller
no flags Details
refresh of console page - shows no apps at all (56.36 KB, image/png)
2013-08-29 10:52 EDT, Diane Mueller
no flags Details

  None (edit)
Description Diane Mueller 2013-08-28 20:25:06 EDT
Description of problem:

The Spring Framework on JBoss EAP6 QuickStart fails. It appears to time out
I am getting to red bar of death message: "Application creation is taking longer than expected. Please wait a few minutes, then refresh this page."

The url is created for the application: 
http://zerosumgame-discovertotems.rhcloud.com/

But when i click on it - i get 'oops! can't find it' message from browser

when i go back to the console to see if it is still listed under 'My Apps" it is gone.


Version-Release number of selected component (if applicable):


How reproducible:

Very reproducible, adam miller gets the same issue

Steps to Reproduce:
1. log in to online
2. choose application Spring Framework on JBoss EAP6
3. keep all default values
4. click on "Create Application"
5. wait

Actual results:

Red Bar of Death appears: "Application creation is taking longer than expected. Please wait a few minutes, then refresh this page."

Application URL is created and clickable

No server found

Application no longer appears under My Apps


Expected results:

Create a sample Maven project


Additional info:
Comment 1 Yujie Zhang 2013-08-28 22:43:42 EDT
Tried on STG and prod, can not reproduce this bug, spring application can be created successfully.
Comment 2 Andy Grimm 2013-08-29 10:30:27 EDT
I looked at your failed attempt, and the maven build took nearly two minutes (and of course that's only part of the total setup time).  In my attempt this morning, it only took 1:15.  I'm not sure what the bottleneck was for you, though.  The node on which you gear landed was not particularly busy, and our nexus server was not busy, either.

I notice that there are references to maven.repository.redhat.com during the build, and I'm not sure whether a slow response from that server could have been the cause of this.  I don't have any view into the past performance metrics of that site, of course.

Please give this another try, and let us know if you are finding it to be easily reproducible.
Comment 3 Diane Mueller 2013-08-29 10:46:00 EDT
Created attachment 791860 [details]
screenshot of default values

these are the default values i used for the spring quickstart
Comment 4 Diane Mueller 2013-08-29 10:47:21 EDT
Created attachment 791861 [details]
here is the screenshot with the error message (again)

note that below the red bar message - I get "url" to click on..
Comment 5 Diane Mueller 2013-08-29 10:49:05 EDT
Created attachment 791863 [details]
attempt to open url in browser results

still does not create the app
Comment 6 Diane Mueller 2013-08-29 10:52:06 EDT
Created attachment 791872 [details]
refresh of console page - shows no apps at all

basically it looks to me like i am getting timed out. My internet connection is decent, i want to be able to demo this via the console. Of note: on this screenshot it still appears that "Maintenance is still occurring" - Open Issue
Comment 7 Diane Mueller 2013-08-29 10:53:40 EDT
Still not creating the app this morning, it's taking a very long time - I would like to be able to do this via the console. Could it be my wifi connection? I can create other apps..can you up my timeout limit?
Comment 8 Diane Mueller 2013-08-29 11:56:46 EDT
Used a 'new' account (discovertotems@gmail.com) and was able to use the quickstart; previously had been using my (dmueller@redhat.com) account.

Not sure what occurred, perhaps my gears counter was not reset properly as I deleted 2 old apps durning the maintenance period, prior to embarking on the Spring Quickstart? 

Got it running now with new account - here:

http://zeroeffort-sechelt.rhcloud.com/
Comment 9 Diane Mueller 2013-08-29 15:05:13 EDT
I will wait ubtil maintenance period is over, and re-try with the dmueller@redhat.com account to see if I can launch it from there. Otherwise, I may need some DevOps clean up on the dmueller@redhat.com's openshift account.
Comment 10 Andy Grimm 2013-09-20 10:13:17 EDT
Diane, are you still having issues with this account / quickstart combination?

Note You need to log in before you can comment on or make changes to this bug.