This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 1002373 - anaconda crash writing network configuration installing from live CD, when network is configured manually
anaconda crash writing network configuration installing from live CD, when ne...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F20AlphaFreezeException F20FinalBlocker
  Show dependency treegraph
 
Reported: 2013-08-28 23:48 EDT by Jim Haynes
Modified: 2013-09-18 22:42 EDT (History)
14 users (show)

See Also:
Fixed In Version: anaconda-20.17-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 22:42:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log file (40.80 KB, text/x-log)
2013-09-04 19:22 EDT, Jim Haynes
no flags Details
ifcfg.log file (1.76 KB, text/x-log)
2013-09-04 19:23 EDT, Jim Haynes
no flags Details
packaging.log (196 bytes, text/x-log)
2013-09-04 19:53 EDT, Jim Haynes
no flags Details
program.log (46.24 KB, text/x-log)
2013-09-04 19:54 EDT, Jim Haynes
no flags Details
storage.log (177.88 KB, text/x-log)
2013-09-04 19:54 EDT, Jim Haynes
no flags Details
report.tar.gz (136.35 KB, application/x-gzip)
2013-09-04 19:55 EDT, Jim Haynes
no flags Details

  None (edit)
Description Jim Haynes 2013-08-28 23:48:24 EDT
Description of problem:Installing from Fedora Live XFCE i686-19-1 CD.


Version-Release number of selected component (if applicable):anaconda 19.30.13-1.fc19.i686


How reproducible:(almost) always


Steps to Reproduce:
1.Boot live CD
2.configure Ethernet
3.Install to hard drive

Actual results: When it gets to the stage where it writes the network
configuration at end of installation, it stays in that state for a long long
time and then gives the Unknown Error failure


Expected results:  Should install and finish normally


Additional info: This is on a system where I configure the network manually,
not using DHCP.  I can install by not configuring the network first, just
let it install and then configure the network after booting up the working
system.

Here are first two lines of the traceback
File "/usr/lib/python2.7/site-packages/pyanaconda/simpleconfig.py", line 77,
in read with open filename as f:
File "/usr/lib/python2.7/site-packages/pyanaconda/simpleconfig.py", line 187,
in read SimpleConfigFile read (self, self.path)
Comment 1 David Shea 2013-08-29 10:07:18 EDT
Can you please attach the full traceback file, along with any other log files in /tmp, to this bug? How are configuring your network interface?
Comment 2 Jim Haynes 2013-08-29 11:20:01 EDT
I would like to have got more trace, but the system froze up while I was
trying to do something with the bug.  Now that I have the system
successfully installed I'm reluctant to go through that time-consuming
process again.  

I booted the Xfce Live CD, left clicked on the little network icon in the
upper right corner, got into the screen where you set the network configuration
and set it.  In my case I use manual configuration, not DHCP, so I selected
manual configuration and put in the IP address, netmask, gateway address
and DNS address.  Then it reported the network wa up and running.

Then I executed the install to hard drive, went through the usual agonizing/
confusing process of setting up the hard drive partitions, got the installer
running.  After it did the installation and the post-install stuff it said
it was saving the network configuration.  It sat in that state for a long
time, many minutes, while I waited for something to happen.  Finally it
opened the window saying an unknown error has occurred.

How do I get to log files in /tmp when I'm in the middle of anaconda with
the error window?
Comment 3 David Shea 2013-08-29 12:09:03 EDT
If the option to report a bug from the traceback window isn't working, you can switch to a shell by hitting Ctrl+Alt+F2.
Comment 4 Jim Haynes 2013-09-04 19:22:28 EDT
Created attachment 793903 [details]
anaconda.log file
Comment 5 Jim Haynes 2013-09-04 19:23:34 EDT
Created attachment 793904 [details]
ifcfg.log file
Comment 6 Jim Haynes 2013-09-04 19:53:32 EDT
Created attachment 793908 [details]
packaging.log
Comment 7 Jim Haynes 2013-09-04 19:54:13 EDT
Created attachment 793909 [details]
program.log
Comment 8 Jim Haynes 2013-09-04 19:54:49 EDT
Created attachment 793910 [details]
storage.log
Comment 9 Jim Haynes 2013-09-04 19:55:23 EDT
Created attachment 793911 [details]
report.tar.gz
Comment 10 Jim Haynes 2013-09-04 20:30:20 EDT
Then I repeated the installation but without configuring the network first,
and as usual it worked correctly.
Comment 11 Radek Vykydal 2013-09-05 07:29:10 EDT
This happens alos with F20 Alpha TC3, Live DVD.
The case is configuring a network device before starting installation, having no more than one wired device.
Comment 12 Kamil Páral 2013-09-05 09:09:06 EDT
After talking to Radek, this is the simplest reproducer:

1. Boot Live image
2. Before running Anaconda, changed wired configuration. Anything that dumps a new config file should be sufficient, probably a change in profile name or disabling ipv6 should be enough. Or you can reconfigure your IP/netmask/dhcp to be sure.
3. Start Anaconda, start installation
4. At the end of the installation, there will be a traceback. Some parts of the system will stay unconfigured, probably a bootloader won't be installed either.

Workaround:
If you need to configure your wired network, do it after you start Anaconda. That shouldn't crash it.

Wireless network should not be affected by this bug.

Proposing as Final Blocker. This is a violation of "The installer must run when launched normally from the release-blocking images." [1] for cases where you need to configure your connection manually, but I don't feel this is common enough to block Alpha or Beta. 

Radek also requested to propose this as Alpha Freeze Exception, he'd like to have it fixed in Alpha, even though the fix will probably not be fully contained and might affect other areas.

[1] https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Installer_must_run
Comment 13 Fedora Update System 2013-09-06 18:43:21 EDT
anaconda-20.12-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.12-1.fc20
Comment 14 Tim Flink 2013-09-06 19:00:41 EDT
(In reply to Kamil Páral from comment #12)

> Radek also requested to propose this as Alpha Freeze Exception, he'd like to
> have it fixed in Alpha, even though the fix will probably not be fully
> contained and might affect other areas.

+1 Alpha Freeze Exception
Comment 15 Kevin Fenzi 2013-09-06 19:12:32 EDT
+1 for Alpha FE
Comment 16 Petr Schindler 2013-09-06 19:20:00 EDT
+1 for AFE
Comment 17 Tim Flink 2013-09-06 19:24:34 EDT
That makes +3 for alpha FE, moving to accepted
Comment 18 Fedora Update System 2013-09-07 13:03:59 EDT
Package anaconda-20.12-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.12-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16040/anaconda-20.12-1.fc20
then log in and leave karma (feedback).
Comment 19 Fedora Update System 2013-09-09 20:12:12 EDT
anaconda-20.13-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.13-1.fc20
Comment 20 Fedora Update System 2013-09-10 15:49:22 EDT
anaconda-20.14-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.14-1.fc20
Comment 21 Fedora Update System 2013-09-11 21:04:23 EDT
anaconda-20.15-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.15-1.fc20
Comment 22 Fedora Update System 2013-09-13 21:06:07 EDT
anaconda-20.16-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.16-1.fc20
Comment 23 Fedora Update System 2013-09-16 13:49:07 EDT
anaconda-20.17-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.17-1.fc20
Comment 24 Kamil Páral 2013-09-17 09:23:45 EDT
I have tested with F20 Alpha RC3 using reproducer in comment 12. The problem is gone, no crashed, installed system is configured properly.
Comment 25 Fedora Update System 2013-09-18 22:42:04 EDT
anaconda-20.17-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.