Bug 1002378 - RFE: Introduce a modular translation structure, and gwt generate the *Messages.properties files
RFE: Introduce a modular translation structure, and gwt generate the *Message...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.4
Assigned To: Patrick Huang
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 00:24 EDT by Damian Jansen
Modified: 2014-07-17 02:39 EDT (History)
3 users (show)

See Also:
Fixed In Version: git-aa31fd676205c4ad428e213cef2dd26030d63f56
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-17 02:39:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damian Jansen 2013-08-29 00:24:44 EDT
Description of problem:
The site translations are a mix of java old-school messages.properties and generated *Messages.properties.
As it stands, the editor strings are not available to the translators.

Version-Release number of selected component (if applicable):
3.0

Requirements:
The zanata-war/-model should be a multi-module project
Gwt generate the *Messages.properties files
Upload these to translate.zanata.org for translation

This will make activities such as:
- translation auto-update
- pseudo-translation testing
- supported locale query

and others more accessible.
Comment 1 Patrick Huang 2014-01-13 20:56:51 EST
https://github.com/zanata/zanata-server/pull/334
Comment 2 Damian Jansen 2014-02-18 21:00:15 EST
Sean - I think I reported this one for you. Does this address the above?
Comment 3 Sean Flanigan 2014-02-18 22:21:39 EST
I haven't tested this feature, but I'd say: more or less.  

Zanata wasn't set up to be a multi-module project after all, but that's because we needed project-type 'properties' for the jsf localisation, and 'utf8properties' for the GWT editor.

Also, there's the problem Dean spotted with the zh_TW_Hant/zh_Hant_TW locale (bug 1063562), which does need fixing before we can actually include future zh-Hant translations in a future release of Zanata.  It needn't block the 3.3 release though.

I think bug 1066203 will be a better solution for our GWT translations, but it requires a minor refactor to the GWT code, so I'd say it is outside this bug's scope.
Comment 4 Damian Jansen 2014-03-04 00:56:55 EST
Verified at aa31fd676205c4ad428e213cef2dd26030d63f56
Comment 5 Sean Flanigan 2014-03-20 20:07:06 EDT
Marking bug as RELEASE_PENDING (Fixed in Version commit is ancestor of origin/master).

Note You need to log in before you can comment on or make changes to this bug.