Bug 1002399 - [RHS-RHOS] mkfs.ext4 hangs at "Creating journal" on cinder volume attached to an instance during rebalance with self-heal
[RHS-RHOS] mkfs.ext4 hangs at "Creating journal" on cinder volume attached to...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On: 999528
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 02:22 EDT by Anush Shetty
Modified: 2014-04-17 07:46 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 999528
Environment:
virt rhos cinder rhs integration
Last Closed: 2014-04-17 07:46:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-08-29 02:56:33 EDT
REVIEW: http://review.gluster.org/5731 (cluster/afr: unlock before aborting transaction) posted (#2) for review on master by Anand Avati (avati@redhat.com)
Comment 2 Anand Avati 2013-08-29 06:36:24 EDT
COMMIT: http://review.gluster.org/5731 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit c8ccfda3a7af1552419ba4f9dfb719fbf0e3f211
Author: Anand Avati <avati@redhat.com>
Date:   Wed Aug 28 22:54:35 2013 -0700

    cluster/afr: unlock before aborting transaction
    
    Else this results in a missing frame causing a hang
    
    Change-Id: Ib5f3dc6a3999449faa2853cee2944af2fb065a20
    BUG: 1002399
    Signed-off-by: Anand Avati <avati@redhat.com>
    Reviewed-on: http://review.gluster.org/5731
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 3 Anand Avati 2013-09-09 20:53:39 EDT
REVIEW: http://review.gluster.org/5878 (cluster/afr: unlock before aborting transaction) posted (#1) for review on release-3.4 by Anand Avati (avati@redhat.com)
Comment 4 Anand Avati 2013-09-09 21:07:05 EDT
REVIEW: http://review.gluster.org/5878 (cluster/afr: unlock before aborting transaction) posted (#2) for review on release-3.4 by Anand Avati (avati@redhat.com)
Comment 5 Anand Avati 2013-09-10 04:21:49 EDT
COMMIT: http://review.gluster.org/5878 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 9cf2c316eabe88d98bfb71f05eea2c5ee3d470c1
Author: Anand Avati <avati@redhat.com>
Date:   Wed Aug 28 22:54:35 2013 -0700

    cluster/afr: unlock before aborting transaction
    
    Else this results in a missing frame causing a hang
    
    Change-Id: Ib5f3dc6a3999449faa2853cee2944af2fb065a20
    BUG: 1002399
    Signed-off-by: Anand Avati <avati@redhat.com>
    Reviewed-on: http://review.gluster.org/5878
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 6 Niels de Vos 2014-04-17 07:46:33 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.