Bug 1002428 - New process definition is added into non-existent package
New process definition is added into non-existent package
Status: CLOSED DUPLICATE of bug 991013
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ---
: 6.0.0
Assigned To: Tihomir Surdilovic
Sona Mala
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 03:54 EDT by Sona Mala
Modified: 2013-09-03 10:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 10:45:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Process definition with Project Explorer and Properties Bar (72.72 KB, image/png)
2013-08-29 03:54 EDT, Sona Mala
no flags Details

  None (edit)
Description Sona Mala 2013-08-29 03:54:33 EDT
Created attachment 791631 [details]
Process definition with Project Explorer and Properties Bar

Description of problem:
If you create new process definition then property "Package" always contains "org.jbpm". No matter in which package you create the process definition or if project contains this package.

See attached screenshot.

Version-Release number of selected component (if applicable):
BPMS 6.0.0 ER2

How reproducible:


Steps to Reproduce:
1. Create a new project "myProject" (org.myproject, 1.0)
2. Check that there is not package "org.jbpm"
3. Create new process definition
4. Take a look at property "Package"

Actual results:
Property "Package" contains "org.jbpm".


Expected results:
I hope that this property should correspondent with package in which is process definition created. The highlighted areas in screen shot should contain same text. For:
   - default package - this property should be empty or contains some expression for default package as "defaultPackage" or "<default>" etc.
   - org.myproject - this property should be org.myproject


Additional info:
I think that property "Package" should not be changed by users.
Comment 1 Marek Baluch 2013-08-29 05:03:30 EDT
See https://bugzilla.redhat.com/show_bug.cgi?id=991013.
Comment 2 Kris Verlaenen 2013-09-03 10:45:23 EDT

*** This bug has been marked as a duplicate of bug 991013 ***

Note You need to log in before you can comment on or make changes to this bug.