Bug 1002447 - virt-who failed to send host/guest info to Satellite when ESXi have no host at all
virt-who failed to send host/guest info to Satellite when ESXi have no host a...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Radek Novacek
John Sefler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 04:50 EDT by gaoshang
Modified: 2016-11-30 19:31 EST (History)
5 users (show)

See Also:
Fixed In Version: virt-who-0.10-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:13:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gaoshang 2013-08-29 04:50:41 EDT
Description of problem:
virt-who failed to send host/guest info to Satellite when ESXi have no host at all, maybe Satellite missed to handle blank message.

Version-Release number of selected component (if applicable):
# rpm -qa | grep virt-who
virt-who-0.8-8.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. Prepare ESXi with no host in it
2. Configure virt-who to connect to Satellite, set VIRTWHO_INTERVAL=5
3. Restart virt-who service

Actual results:
virt-who should send blank h/g info every 5 seconds

Expected results:
virt-who halt for Satellite

Additional info:
Log info for Satellite, virt-who hang up there even though VIRTWHO_INTERVAL=5:

    2013-08-29 04:28:04,617 [WARNING]  @virt-who.py:502 - Listening for events is not available in VDSM, ESX, RHEV-M or Hyper-V mode
    2013-08-29 04:28:04,618 [DEBUG]  @satellite.py:49 - Initializing satellite connection to https://10.16.64.212/XMLRPC
    2013-08-29 04:28:04,618 [INFO]  @satellite.py:55 - Initialized satellite connection
    2013-08-29 04:28:09,811 [DEBUG]  @virt-who.py:515 - Virt-who is running in esx mode
    2013-08-29 04:28:09,812 [DEBUG]  @virt-who.py:522 - Starting infinite loop with 5 seconds interval and event handling


By comparison, virt-who behaves in SAM:

    2013-08-29 04:27:12,225 [WARNING]  @virt-who.py:502 - Listening for events is not available in VDSM, ESX, RHEV-M or Hyper-V mode
    2013-08-29 04:27:17,775 [DEBUG]  @virt-who.py:515 - Virt-who is running in esx mode
    2013-08-29 04:27:17,775 [DEBUG]  @virt-who.py:522 - Starting infinite loop with 5 seconds interval and event handling
    2013-08-29 04:27:17,821 [DEBUG]  @subscriptionmanager.py:89 - Sending update in hosts-to-guests mapping: {}
    2013-08-29 04:27:23,029 [DEBUG]  @subscriptionmanager.py:89 - Sending update in hosts-to-guests mapping: {}
    2013-08-29 04:27:28,233 [DEBUG]  @subscriptionmanager.py:89 - Sending update in hosts-to-guests mapping: {}
Comment 2 RHEL Product and Program Management 2013-10-13 22:30:00 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Radek Novacek 2014-06-02 13:37:22 EDT
This bug is fixed upstream and will be resolved by rebase of virt-who, see bug 1002640.
Comment 4 Radek Novacek 2014-06-18 03:29:34 EDT
This bug is fixed by rebase to virt-who-0.10-1.el6.
Comment 6 gaoshang 2014-08-04 00:19:40 EDT
This bug has been verified against virt-who-0.10-4.el6.noarch and passed.
Comment 7 errata-xmlrpc 2014-10-14 03:13:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1513.html

Note You need to log in before you can comment on or make changes to this bug.