This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1002473 - Error Code: 0x0000007F at first reboot after fresh installing windows 8 32bit guest on AMD system
Error Code: 0x0000007F at first reboot after fresh installing windows 8 32bit...
Status: CLOSED DUPLICATE of bug 1023268
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 05:50 EDT by Chao Yang
Modified: 2014-04-15 16:25 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-15 16:25:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error code and parameters (9.72 KB, image/png)
2013-08-29 05:50 EDT, Chao Yang
no flags Details

  None (edit)
Description Chao Yang 2013-08-29 05:50:47 EDT
Created attachment 791662 [details]
error code and parameters

Description of problem:
I hit 'Error code: 0x0000007F' at first reboot after fresh installing a windows 8 32 bit system on an AMD system. Screenshot will be attached.

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-0.12.1.2-2.398.el6.x86_64
2.6.32-414.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
# cat /proc/cpuinfo
....

processor	: 15
vendor_id	: AuthenticAMD
cpu family	: 21
model		: 1
model name	: AMD Opteron(tm) Processor 4284                 
stepping	: 2
cpu MHz		: 2999.919
cache size	: 2048 KB
physical id	: 1
siblings	: 8
core id		: 7
cpu cores	: 4
apicid		: 23
initial apicid	: 23
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nonstop_tsc extd_apicid aperfmperf pni pclmulqdq monitor ssse3 cx16 sse4_1 sse4_2 popcnt aes xsave avx lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt lwp fma4 nodeid_msr topoext perfctr_core cpb npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold
bogomips	: 5999.13
TLB size	: 1536 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 48 bits physical, 48 bits virtual
power management: ts ttp tm 100mhzsteps hwpstate cpb

CLI:
-M rhel6.5.0 -cpu Opteron_G4 -enable-kvm -m 2048 -realtime mlock=off -smp 2,sockets=2,cores=1,threads=1 -uuid 55e5def1-1b15-43e0-b05e-778914534cc8 -smbios type=1,manufacturer=Red Hat,product=RHEV Hypervisor,version=6Server-6.5.0.0.el6,serial=4C4C4544-0039-3610-8047-B9C04F463358,uuid=55e5def1-1b15-43e0-b05e-778914534cc8 -nodefconfig -nodefaults -rtc base=2013-08-29T07:40:05,driftfix=slew -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x5 -drive file=en_windows_8_enterprise_x86_dvd_917587.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw,serial= -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=test.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,serial=71e94c44-236d-4f57-8a6e-82bfa7fc6fcd,cache=none,werror=stop,rerror=stop,aio=native -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x6,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -net none -chardev spicevmc,id=charchannel2,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=3,chardev=charchannel2,id=channel2,name=com.redhat.spice.0 -spice port=7000,disable-ticketing,seamless-migration=on -k en-us -vga qxl -global qxl-vga.ram_size=67108864 -global qxl-vga.vram_size=67108864 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7 -monitor stdio -boot menu=on -fda virtio-win-1.6.5_x86.vfd
Comment 2 Vadim Rozenfeld 2013-09-06 05:55:53 EDT
your system disk is virtio-blk right? Can it boot successfully if you you change
it to ide? What is the virtio-block driver version?

Thanks,
Vadim.
Comment 3 Chao Yang 2013-09-08 23:03:01 EDT
(In reply to Vadim Rozenfeld from comment #2)
> your system disk is virtio-blk right? Can it boot successfully if you you
> change
Yes, it is virtio-blk.

> it to ide? What is the virtio-block driver version?
>
Changing to ide didn't help. And I also retied fresh installing win8 x86 into an ide disk, failed with same error code and parameters, either.
The virtio-block driver is provided by virtio-win-1.6.5-5.el6_4
> Thanks,
> Vadim.
Comment 4 Vadim Rozenfeld 2013-09-09 21:09:57 EDT
Thanks.
Also reproducible with Opteron_G4.
The BSOD is generated by #GP trap handler (KiTrap0D).
Vadim.
Comment 5 Ronen Hod 2013-09-17 08:16:59 EDT
Deferring to 6.6.
KVM upstream first.
Comment 8 Radim Krčmář 2014-03-18 12:26:58 EDT
Equivalent bug was fixed in rhel7.
https://bugzilla.redhat.com/show_bug.cgi?id=1023261#c12 has few patches we might want.
Comment 11 Radim Krčmář 2014-04-15 16:25:39 EDT
Thanks.

From information provided in Comment #10,

*** This bug has been marked as a duplicate of bug 1023268 ***

Note You need to log in before you can comment on or make changes to this bug.