Bug 1002477 - maven-eclipse-plugin: Migrate from easymock 1 to easymock 3
maven-eclipse-plugin: Migrate from easymock 1 to easymock 3
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: maven-eclipse-plugin (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 811105
  Show dependency treegraph
 
Reported: 2013-08-29 05:51 EDT by Mikolaj Izdebski
Modified: 2013-08-29 09:30 EDT (History)
5 users (show)

See Also:
Fixed In Version: 2.9-9
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 09:30:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2013-08-29 05:51:31 EDT
Description of problem:
Package maven-eclipse-plugin requires or build-requires easymock package, version 1.x.
In Fedora currently we have versions 1 and 3 packaged.
All packages depending on easymock version 1 should update their
dependencies to easymock3 so that we can reture easymock version 1.x.

Version-Release number of selected component (if applicable):
2.9-7

Additional info:
[1] http://fedoraproject.org/wiki/Packaging:Java
[2] http://fedoraproject.org/wiki/Packaging:Guidelines
Comment 1 Mikolaj Izdebski 2013-08-29 08:35:37 EDT
Fixed in maven-eclipse-plugin-2.9-8
Comment 2 Mikolaj Izdebski 2013-08-29 08:58:45 EDT
Fixed in maven-eclipse-plugin-2.9-9
Comment 3 Mikolaj Izdebski 2013-08-29 09:30:12 EDT
I believe that this bug is fixed in maven-eclipse-plugin-2.9-9,
which is available in Fedora 20, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=460165

Note You need to log in before you can comment on or make changes to this bug.