Bug 1002490 - virsh cpu-baseline doesn't print error message for empty file argument
virsh cpu-baseline doesn't print error message for empty file argument
Status: CLOSED DUPLICATE of bug 889276
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Libvirt Maintainers
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 06:19 EDT by Pavel Hrdina
Modified: 2013-09-04 09:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-04 09:41:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Hrdina 2013-08-29 06:19:01 EDT
Description of problem:
The virsh command 'cpu-baseline' doesn't print eny error message into stderr for emtpy file argument. This bug has been discovered by libvirt-autotest.

Version-Release number of selected component (if applicable):
libvirt-0.10.2-23.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. virsh cpu-baseline ''

Actual results:
echo $? -> 1
stderr -> nothing

Expected results:
echo $? -> 1
stderr -> error: Failed to get option 'file': Option argument is empty

Additional info:
The error message is from upstream libvirt.
Comment 1 Peter Krempa 2013-08-29 06:26:34 EDT
This was fixed upstream by commit:

commit fa956d9055c6fc1aaf672172343172da113f5e47
Author: Peter Krempa <pkrempa@redhat.com>
Date:   Mon Jan 21 15:39:18 2013 +0100

    virsh-domain: Update domain commands to use vshCommandOptStringReq
Comment 4 Jiri Denemark 2013-09-04 09:41:44 EDT

*** This bug has been marked as a duplicate of bug 889276 ***

Note You need to log in before you can comment on or make changes to this bug.