Bug 1002503 - Empty selectbox to set time zone in the kickstart profile of Fedora
Empty selectbox to set time zone in the kickstart profile of Fedora
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
560
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2013-08-29 06:45 EDT by Martin Korbel
Modified: 2013-08-30 06:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-30 06:39:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart profile (64.81 KB, image/png)
2013-08-29 06:45 EDT, Martin Korbel
no flags Details

  None (edit)
Description Martin Korbel 2013-08-29 06:45:13 EDT
Created attachment 791698 [details]
kickstart profile

Description of problem:
Empty selectbox to set time zone in the kickstart profile of Fedora.
(look at attachment kickstart-profile-fedora.png)

Version-Release number of selected component (if applicable):
Sat 5.6.0@RHEL6  (kickstart profile for Fedora 19)
Sat 5.5.0@RHEL6  (kickstart profile for Fedora 16)
SW  2.0@Centos6  (kickstart profile for Fedora 19)

How reproducible:
100%

Steps to Reproduce:
1. Create repo and channel for Fedora. We don't need to do synchronize.
> spacewalk-common-channels -u admin -p xxx -a i386 fedora19
2. Download Fedora DVD and mount it.
> wget http://download.englab.brq.redhat.com/released/F-19/GOLD/Fedora/i386/iso/Fedora-19-i386-DVD.iso
> mkdir /srv/Fedora19-i386
# disable selinux, because mounted DVD has got "iso9660_t" selinux type and satellite doesn't have a right to read it.
> setenforce 0
> mount -o loop Fedora-19-i386-DVD.iso /srv/Fedora19-i386
3. Add distribution
> spacewalk-api --server=localhost --user=admin --password=xxx kickstart.tree.create "%session%" distro-fedora19-i386 /srv/Fedora19-i386  fedora19-i386 fedora
4. Create kickstart profile
> spacewalk-api --server=localhost --user=admin --password=xxx kickstart.createProfile "%session%" ks-fedora19-i386 none distro-fedora19-i386 $(hostname) redhat
5. Open Systems > Kickstart > profiles > ks-fedora19-i386 > System Details > Locale


Actual results:
Empty selectbox

Expected results:
List of timezones

Additional info:
no tracebacks in logs
Comment 1 Tomas Lestach 2013-08-29 09:19:53 EDT
Right, for Fedora(s) we do not list any timezones in the rhnKickstartTimezone table. That is why the selectbox is empty.
So, we need to get the list of supported timezones from a running fedora system and populate rhnKickstartTimezone table similar to commit 3f9ae912 fo rhel_7.

Not a regression.
Comment 3 Clifford Perry 2013-08-30 06:39:44 EDT
Since we don't support Fedora, we won't fix this as a Satellite bug. 

If needed, create a spacewalk BZ. 

Cliff

Note You need to log in before you can comment on or make changes to this bug.