Bug 1002509 - In Process Instances, finished instance shown also as active
In Process Instances, finished instance shown also as active
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ER4
: 6.0.0
Assigned To: Mauricio Salatino
Zuzana Krejčová
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 07:03 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:08:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
process-reproducer (8.62 KB, application/xml)
2013-08-29 07:03 EDT, Zuzana Krejčová
no flags Details

  None (edit)
Description Zuzana Krejčová 2013-08-29 07:03:25 EDT
Created attachment 791702 [details]
process-reproducer

Description of problem:
Shorter version - the business-central process instances perspective can show an instance both as active and as completed at the same time. Trying to abort such an instance fails with "Could not find process instance for id <id>"

Longer version:
You can create a process with a timer node that has an invalid duration defined. It is possible to run an instance of this process from the business-central. The timer node is immediately passed as if nothing is wrong. In the database, in processinstancelog table, there is both a record of this instance as active and as completed.
This results in this instance shown in the business-central as both active and completed, since that is where the information about process instances is taken from for the gui. Unfortunately, if you try to abort this instance, you get an ugly stacktrace about "Could not find process instance for id <id>" - since that instance is not active any longer and is not therefore in the processinstanceinfo table.

The process to reproduce this is attached. Tested on PostgreSQL 9.1.


Version-Release number of selected component (if applicable):
BPMS 6.0 ER2
Comment 1 Mauricio Salatino 2013-09-18 09:29:01 EDT
This is already fixed in master and 6.0.x since I couldn't reproduce the issue with the attached process. I've tested with H2 and it was working as expected. the Process is executed and the system.out appears in the console

Note You need to log in before you can comment on or make changes to this bug.