Bug 1002511 - File operations caused smbd process to crash
File operations caused smbd process to crash
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: libgfapi (Show other bugs)
pre-release
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Raghavendra Talur
Sudhir D
:
Depends On: 1001614
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 07:10 EDT by Poornima G
Modified: 2014-04-17 07:46 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1001614
Environment:
Last Closed: 2014-04-17 07:46:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-08-29 07:50:39 EDT
REVIEW: http://review.gluster.org/5733 (api/src: Add null check for active_subvol in glfs_close.) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 2 Anand Avati 2013-08-29 07:53:10 EDT
REVIEW: http://review.gluster.org/5733 (api: Add null check for active_subvol in glfs_close.) posted (#2) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 3 Anand Avati 2013-08-29 17:12:31 EDT
COMMIT: http://review.gluster.org/5733 committed in master by Anand Avati (avati@redhat.com) 
------
commit 479087c1e670faea4a0ef7a6d13a9869ef9de69f
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Thu Aug 29 17:17:14 2013 +0530

    api: Add null check for active_subvol in glfs_close.
    
    Problem:
    In glfs_close, NULL value returned by glfs_active_subvol was not
    being checked and was causing a crash.
    
    Change-Id: I6eefa60e7b07dee251b98932b1d08a5c2981d3d7
    BUG: 1002511
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/5733
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 4 Anand Avati 2013-09-09 20:52:40 EDT
REVIEW: http://review.gluster.org/5876 (api: Add null check for active_subvol in glfs_close.) posted (#1) for review on release-3.4 by Anand Avati (avati@redhat.com)
Comment 5 Anand Avati 2013-09-09 21:08:07 EDT
REVIEW: http://review.gluster.org/5876 (api: Add null check for active_subvol in glfs_close.) posted (#2) for review on release-3.4 by Anand Avati (avati@redhat.com)
Comment 6 Anand Avati 2013-09-10 04:19:41 EDT
COMMIT: http://review.gluster.org/5876 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 4995efd2280ceb2668145277984c5ea4a0af6e30
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Thu Aug 29 17:17:14 2013 +0530

    api: Add null check for active_subvol in glfs_close.
    
    Problem:
    In glfs_close, NULL value returned by glfs_active_subvol was not
    being checked and was causing a crash.
    
    Change-Id: I6eefa60e7b07dee251b98932b1d08a5c2981d3d7
    BUG: 1002511
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/5876
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 7 Niels de Vos 2014-04-17 07:46:40 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.