Bug 1002534 - Pegasus badly handles null characters
Pegasus badly handles null characters
Status: CLOSED DUPLICATE of bug 1007386
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tog-pegasus (Show other bugs)
7.0
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Vitezslav Crhonek
qe-baseos-daemons
:
Depends On:
Blocks: 922084
  Show dependency treegraph
 
Reported: 2013-08-29 08:05 EDT by Petr Sklenar
Modified: 2013-09-16 07:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 07:13:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2013-08-29 08:05:23 EDT
Description of problem:
Account provider: create user with null char

Version-Release number of selected component (if applicable):
openlmi-account-0.1.1-2.el7.x86_64

How reproducible:
always

Steps to Reproduce:
code:

cs = self.conn.root.cimv2.Linux_ComputerSystem.first_instance()
lams = self.conn.root.cimv2.LMI_AccountManagementService.first_instance()
user = lams.CreateAccount(Name=chr(0), System=cs)

Actual results:
it doesn't do anything

Expected results:
there is an error and it doesn't stack

Additional info:
Comment 2 Roman Rakus 2013-08-30 04:17:39 EDT
Does it make the same output if you pass an empty string? (Name='')
Comment 3 Petr Sklenar 2013-08-30 04:55:21 EDT
(In reply to Roman Rakus from comment #2)
> Does it make the same output if you pass an empty string? (Name='')
Actually its not about empty string but null string:

>>> account2a = account2.CreateAccount(Name='', System=cs)
>>> account2a
LMIReturnValue(rval=-1, rparams={}, errorstr=u"CIM_ERR_FAILED: Error creating group: unknown error\n: 'CreateAccount'")
>>> account2a = account2.CreateAccount(Name=chr(0), System=cs)
### here it stucks

There could be 'error unknown' or better "Error creating group: name contains invalid char."

The main: it shouldn't stuck with bugfix.
Comment 4 Roman Rakus 2013-08-30 08:46:17 EDT
Looks like it does not go into provider, it is stuck in the Pegasus.

We can learn lmi shell to not pass null.
Comment 6 Vitezslav Crhonek 2013-09-16 07:13:37 EDT

*** This bug has been marked as a duplicate of bug 1007386 ***

Note You need to log in before you can comment on or make changes to this bug.