Bug 1002541 - Different restriction for "Repository Label" for create repo using WebUI and API
Different restriction for "Repository Label" for create repo using WebUI and API
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
560
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Gennadii Altukhov
Red Hat Satellite QA List
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2013-08-29 08:19 EDT by Martin Korbel
Modified: 2016-03-17 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-17 12:31:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Korbel 2013-08-29 08:19:30 EDT
Description of problem:
Different restriction for "Repository Label" for create repo  using WebUI and API.
WebUI removes brackets from "Repository Label", API doesn't do it.

Version-Release number of selected component (if applicable):
100%

How reproducible:
Sat 5.6.0
Sat 5.5.0
SW 2.0

Steps to Reproduce:
1. Create repo using API
> spacewalk-api --server=localhost --user=admin --password=xxx  channel.software.createRepo "%session%" "Fedora 19 (i386)" YUM http://download.englab.brq.redhat.com/released/F-19/GOLD/Everything/i386/
2. Create repo using WebUI.
Repository Label: Fedora 19 (x86_64)
Repository URL: http://download.englab.brq.redhat.com/released/F-19/GOLD/Everything/x86_64/
3. Click "Create repository" and we can see, that WebUI saves label without brackets:
Repository Label: Fedora 19 x86_64


Actual results:
Repository Label: Fedora 19 x86_64

Expected results:
Repository Label: Fedora 19 (x86_64)

Additional info:
Comment 2 Gennadii Altukhov 2016-03-16 08:49:06 EDT
Taking...
Comment 3 Gennadii Altukhov 2016-03-17 12:31:24 EDT
This is kind of "feature", but not a bug. We're removing all characters like "<", ">", "(", ")", "{", "}", from web-UI forms. I see no sense to do this only for one API-call now.

Closing...

Note You need to log in before you can comment on or make changes to this bug.