Bug 1002546 - Missing Dependency: python-setuptools.noarch
Missing Dependency: python-setuptools.noarch
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: transifex-client (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luis Bazan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 08:31 EDT by Alexandre Moine
Modified: 2013-10-22 01:03 EDT (History)
5 users (show)

See Also:
Fixed In Version: transifex-client-0.9-4.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-12 12:41:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Moine 2013-08-29 08:31:11 EDT
Description of problem:
When I try 'tx init', it returns:

Traceback (most recent call last):
  File "/bin/tx", line 9, in <module>
    from txclib import utils
  File "/usr/lib/python2.7/site-packages/txclib/utils.py", line 12, in <module>
    from txclib.web import verify_ssl
  File "/usr/lib/python2.7/site-packages/txclib/web.py", line 11, in <module>
    from pkg_resources import resource_filename, resource_string
ImportError: No module named pkg_resources

The solution is to install python-setuptools.noarch 


Version-Release number of selected component (if applicable): transifex-client-0.9-2.fc19


Steps to Reproduce:
1. Remove transifex-client and python-setuptools
2. Install transifex-client
3. Run tx init

Actual results:
Traceback (most recent call last):
  File "/bin/tx", line 9, in <module>
    from txclib import utils
  File "/usr/lib/python2.7/site-packages/txclib/utils.py", line 12, in <module>
    from txclib.web import verify_ssl
  File "/usr/lib/python2.7/site-packages/txclib/web.py", line 11, in <module>
    from pkg_resources import resource_filename, resource_string
ImportError: No module named pkg_resources

Expected results:
Creating .tx folder...
Transifex instance [https://www.transifex.com]:

Additional info:
Comment 1 Fedora Update System 2013-09-04 21:46:49 EDT
transifex-client-0.9-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/transifex-client-0.9-3.fc19
Comment 2 Fedora Update System 2013-09-06 01:18:40 EDT
Package transifex-client-0.9-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing transifex-client-0.9-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15911/transifex-client-0.9-3.fc19
then log in and leave karma (feedback).
Comment 3 Alexandre Moine 2013-09-07 14:01:10 EDT
The update wasn't fix the bug
Comment 4 Fedora Update System 2013-10-10 16:24:25 EDT
transifex-client-0.9-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/transifex-client-0.9-4.fc18
Comment 5 Fedora Update System 2013-10-10 16:27:02 EDT
transifex-client-0.9-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/transifex-client-0.9-4.fc19
Comment 6 Fedora Update System 2013-10-10 16:35:55 EDT
transifex-client-0.9-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/transifex-client-0.9-4.el6
Comment 7 Fedora Update System 2013-10-11 14:03:41 EDT
Package transifex-client-0.9-4.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing transifex-client-0.9-4.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11819/transifex-client-0.9-4.el6
then log in and leave karma (feedback).
Comment 8 Alexandre Moine 2013-10-12 11:59:49 EDT
Hi,

The update wasn't fix the problem. Please add the "Requires: python-setuptools" on your spec.

Thank you in advance
Comment 9 Luis Bazan 2013-10-12 12:19:27 EDT
Hi nobrakal this new version 0.9-4 have the require. 

%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}

Name:           transifex-client
Version:        0.9
Release:        4%{?dist}
Summary:        Command line tool for Transifex translation management

Group:          Development/Languages
License:        GPLv2
URL:            http://transifex.org
Source:         http://pypi.python.org/packages/source/t/transifex-client/%{name}-%{version}.tar.gz
BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

BuildArch:      noarch
Requires:       python-setuptools
BuildRequires:  python-devel
BuildRequires:  python-setuptools
Comment 10 Luis Bazan 2013-10-12 12:24:43 EDT
mmmm in el6 need the requires sorry.... let me fix that..

Regards!
Comment 12 Luis Bazan 2013-10-12 12:40:06 EDT
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}

Name:           transifex-client
Version:        0.9
Release:        5%{?dist}
Summary:        Command line tool for Transifex translation management

Group:          Development/Languages
License:        GPLv2
URL:            http://transifex.org
Source:         http://pypi.python.org/packages/source/t/transifex-client/%{name}-%{version}.tar.gz
BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

BuildArch:      noarch
Requires:       python-setuptools
BuildRequires:  python-devel
BuildRequires:  python-setuptools
Comment 13 Alexandre Moine 2013-10-12 12:41:23 EDT
Works for me, thank you very much :)

Regards!
Comment 14 Fedora Update System 2013-10-14 12:05:47 EDT
transifex-client-0.9-5.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2013-10-22 01:01:07 EDT
transifex-client-0.9-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2013-10-22 01:03:16 EDT
transifex-client-0.9-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.