Bug 1002577 - Add brick operation is causing one of the smbd process in server to crash
Add brick operation is causing one of the smbd process in server to crash
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: libgfapi (Show other bugs)
mainline
Unspecified Unspecified
high Severity urgent
: ---
: ---
Assigned To: Raghavendra Talur
Sudhir D
:
Depends On: 1000545
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 09:17 EDT by Raghavendra Talur
Modified: 2014-04-17 07:46 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1000545
Environment:
Last Closed: 2014-04-17 07:46:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-08-29 09:37:25 EDT
REVIEW: http://review.gluster.org/5734 (api: Fill loc.path and loc.gfid before syncop_open.) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 2 Anand Avati 2013-08-29 09:41:44 EDT
REVIEW: http://review.gluster.org/5734 (api: Fill loc.path and loc.gfid before syncop_open.) posted (#2) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 3 Anand Avati 2013-08-29 16:53:09 EDT
COMMIT: http://review.gluster.org/5734 committed in master by Anand Avati (avati@redhat.com) 
------
commit 2ec4b22bb02f572f74157df5264b247095fece77
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Thu Aug 29 19:04:40 2013 +0530

    api: Fill loc.path and loc.gfid before syncop_open.
    
    syncop_open was crashing because of NULL dereference.
    This fixes that.
    
    Change-Id: I4bc48fac2a6c0b15c806cbbb4ae45c67891ab7ed
    BUG: 1002577
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/5734
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 4 Anand Avati 2013-09-09 20:53:10 EDT
REVIEW: http://review.gluster.org/5877 (api: Fill loc.path and loc.gfid before syncop_open.) posted (#1) for review on release-3.4 by Anand Avati (avati@redhat.com)
Comment 5 Anand Avati 2013-09-09 21:07:38 EDT
REVIEW: http://review.gluster.org/5877 (api: Fill loc.path and loc.gfid before syncop_open.) posted (#2) for review on release-3.4 by Anand Avati (avati@redhat.com)
Comment 6 Anand Avati 2013-09-10 04:20:56 EDT
COMMIT: http://review.gluster.org/5877 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 236216cba153cb2c270e63698ecb073601287fd4
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Thu Aug 29 19:04:40 2013 +0530

    api: Fill loc.path and loc.gfid before syncop_open.
    
    syncop_open was crashing because of NULL dereference.
    This fixes that.
    
    Change-Id: I4bc48fac2a6c0b15c806cbbb4ae45c67891ab7ed
    BUG: 1002577
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/5877
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 7 Niels de Vos 2014-04-17 07:46:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.