Bug 1002616 - Can not change any properties in running Linux VMs imported from RHEV 2.2
Can not change any properties in running Linux VMs imported from RHEV 2.2
Status: CLOSED DUPLICATE of bug 988259
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
All Linux
high Severity high
: ---
: ---
Assigned To: nobody nobody
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 10:46 EDT by Julio Entrena Perez
Modified: 2013-08-30 02:52 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-30 02:52:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 465813 None None None Never

  None (edit)
Description Julio Entrena Perez 2013-08-29 10:46:06 EDT
Description of problem:
Any attempt to change any property of a running Linux VM which has been imported from RHEV 2.2 fails with "Failed updating the properties of the VM.".

/var/log/ovirt-engine/engine.log shows the following:
ERROR [org.ovirt.engine.core.utils.ObjectIdentityChecker] (ajp-/127.0.0.1:8702-15) [de80ed8] Field timeZone can not be updated when status is Up
WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (ajp-/127.0.0.1:8702-15) [de80ed8] ObjectIdentityChecker.IsUpdateValid:: Not updatable field 'timeZone' was updated
WARN  [org.ovirt.engine.core.bll.UpdateVmCommand] (ajp-/127.0.0.1:8702-15) [de80ed8] CanDoAction of action UpdateVm failed. Reasons:VAR__ACTION__UPDATE,VAR__TYPE__VM,VM_CANNOT_UPDATE_ILLEGAL_FIELD

Version-Release number of selected component (if applicable):
rhevm-backend-3.2.1-0.39.el6ev

How reproducible:
Always

Steps to Reproduce:
1. Export a Linux VM from RHEV 2.2.
2. Import that Linux VM in RHEV 3.2.
3. In webadmin portal go to "Virtual Machines", select the VM and click "Edit".
4. Try to change any property and click OK.

Actual results:
<vm_name>:

    Failed updating the properties of the VM. This may be caused either by:
    1. The values selected are not appropriate for the VM; or
    2. Its values cannot be updated while the VM is in UP state (Please shut down the VM in order to modify properties such as CPU or cluster).

Also /var/log/ovirt-engine/engine.log shows the following:
ERROR [org.ovirt.engine.core.utils.ObjectIdentityChecker] (ajp-/127.0.0.1:8702-15) [de80ed8] Field timeZone can not be updated when status is Up
WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (ajp-/127.0.0.1:8702-15) [de80ed8] ObjectIdentityChecker.IsUpdateValid:: Not updatable field 'timeZone' was updated
WARN  [org.ovirt.engine.core.bll.UpdateVmCommand] (ajp-/127.0.0.1:8702-15) [de80ed8] CanDoAction of action UpdateVm failed. Reasons:VAR__ACTION__UPDATE,VAR__TYPE__VM,VM_CANNOT_UPDATE_ILLEGAL_FIELD

Expected results:
Properties are updated successfully.

Additional info:
.OVF files created by RHEV 2.2 in export domain during export contain a value for the Windows domain field:

$ xmllint --format 0a559483-5c1f-42b3-a895-ee8250a7f6e4.ovf | egrep -i "domain|timezone"
    <Domain>MYDOMAIN</Domain>
    <TimeZone/>

RHEV 3.2 should disregard Windows domain for Linux VMs.

Workaround is to stop engine service, update the database by ensuring that Windows domain and timezone properties are set to NULL and start engine service back:

engine=# update vm_static set domain=NULL, time_zone=NULL where vm_name='<vm_name>';

This might be a duplicate of Bugzilla 1000034 .
Comment 2 Itamar Heim 2013-08-30 02:52:31 EDT

*** This bug has been marked as a duplicate of bug 988259 ***

Note You need to log in before you can comment on or make changes to this bug.