Bug 1002624 - Content Search - package details are incorrectly rendered
Content Search - package details are incorrectly rendered
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Garik Khachikyan
: Triaged
: 996476 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 11:20 EDT by Mike McCune
Modified: 2015-01-04 17:00 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2013-08-29 11:20:56 EDT
via:

https://github.com/Katello/katello/issues/2801

Scenario:

    sync a RHEL repo
    go to Content -> Content Search
    select Content -> Packages
    click Search
    navigate to the RHEL repo and hover on a package

The format for various fields is not user friendly. For example:

    example requires:
    {"release"=>nil, "epoch"=>"0", "version"=>"6.75", "flags"=>"GE", "name"=>"initscripts"}

    example provides:
    {"release"=>"12.P1.el6", "epoch"=>"12", "version"=>"4.1.1", "flags"=>"EQ", "name"=>"dhclient"}

    example from View Package Files:

["file", ["/etc/NetworkManager/dispatcher.d/10-dhclient", "/sbin/dhclient", "/sbin/dhclient-script", "/usr/lib64/pm-utils/sleep.d/56dhclient", "/usr/share/doc/dhclient-4.1.1/README.dhclient.d", "/usr/share/doc/dhclient-4.1.1/dhclient.conf.sample", "/usr/share/doc/dhclient-4.1.1/dhclient6.conf.sample", "/usr/share/man/man5/dhclient.conf.5.gz", "/usr/share/man/man5/dhclient.leases.5.gz", "/usr/share/man/man5/dhcp-eval.5.gz", "/usr/share/man/man5/dhcp-options.5.gz", "/usr/share/man/man8/dhclient-script.8.gz", "/usr/share/man/man8/dhclient.8.gz"]]
["dir", ["/etc/NetworkManager", "/etc/NetworkManager/dispatcher.d", "/etc/dhcp", "/etc/dhcp/dhclient.d", "/usr/share/doc/dhclient-4.1.1", "/var/lib/dhclient"]]

This needs to be rendered in a user-friendly manner.

In addition to the above, some of this content is being indexed in elasticsearch (e.g. requires & provides); therefore, we need to make sure that the content indexed is usable.
Comment 1 Brad Buckingham 2013-09-13 14:27:42 EDT
Apologies, I had started working on the github issue already, so I'm going to reassign this one back to me.
Comment 2 Brad Buckingham 2013-09-13 15:59:10 EDT
katello pull request: 
https://github.com/Katello/katello/pull/2944
Comment 3 Brad Buckingham 2013-09-18 14:47:14 EDT
*** Bug 996476 has been marked as a duplicate of this bug. ***
Comment 6 Garik Khachikyan 2013-10-21 09:13:03 EDT
# VERIFIED

the provides/requires section looks more user-friendly and has format of:
---
Name:

dhclient
ID:

ccf49ec3-6e4a-4faa-b5da-b6686f547fa4
Description:

DHCP (Dynamic Host Configuration Protocol) is a protocol which allows individual devices on an IP network to get their own network configuration information (IP address, subnetmask, broadcast address, etc.) from a DHCP server. The overall purpose of DHCP is to make it easier to administer a large network. To use DHCP on your network, install a DHCP service (or relay agent), and on clients run a DHCP client daemon. The dhclient package provides the ISC DHCP client daemon.
Architecture:

x86_64
Signature:

sha : 897b3e4b571dc35d378f7778581dc729d8d9999b
Build Host:

x86-002.build.bos.redhat.com
License:

x86-002.build.bos.redhat.com
Requires:

 

/bin/bash

/bin/sh

/bin/sh

coreutils

grep

initscripts >= 0:6.75

libc.so.6()(64bit)

libc.so.6(GLIBC_2.2.5)(64bit)

libc.so.6(GLIBC_2.3)(64bit)

libc.so.6(GLIBC_2.3.4)(64bit)

libc.so.6(GLIBC_2.4)(64bit)

libc.so.6(GLIBC_2.8)(64bit)

libcap-ng.so.0()(64bit)

rtld(GNU_HASH)
Provides:

 

dhclient = 12:4.1.1-19.P1.el6_1.1

dhclient(x86-64) = 12:4.1.1-19.P1.el6_1.1

dhcpcd = 0:1.3.22pl1-8
---

checked on a system with:
===
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.3.0-18.el6sat.noarch
* foreman-compute-1.3.0-18.el6sat.noarch
* foreman-libvirt-1.3.0-18.el6sat.noarch
* foreman-postgresql-1.3.0-18.el6sat.noarch
* foreman-proxy-1.3.0-3.el6sat.noarch
* katello-1.4.6-39.el6sat.noarch
* katello-all-1.4.6-39.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.4-1.el6sat.noarch
* katello-cli-1.4.3-24.el6sat.noarch
* katello-cli-common-1.4.3-24.el6sat.noarch
* katello-common-1.4.6-39.el6sat.noarch
* katello-configure-1.4.7-5.el6sat.noarch
* katello-configure-foreman-1.4.7-5.el6sat.noarch
* katello-configure-foreman-proxy-1.4.7-5.el6sat.noarch
* katello-foreman-all-1.4.6-39.el6sat.noarch
* katello-glue-candlepin-1.4.6-39.el6sat.noarch
* katello-glue-elasticsearch-1.4.6-39.el6sat.noarch
* katello-glue-pulp-1.4.6-39.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.4-4.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.0-0.22.beta.el6sat.noarch
* pulp-nodes-parent-2.3.0-0.22.beta.el6sat.noarch
* pulp-puppet-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-rpm-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-selinux-2.3.0-0.22.beta.el6sat.noarch
* pulp-server-2.3.0-0.22.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.7-1.el6sat.noarch
* signo-0.0.22-2.el6sat.noarch
* signo-katello-0.0.22-2.el6sat.noarch
Comment 7 Bryan Kearney 2014-04-24 13:10:39 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 8 Bryan Kearney 2014-04-24 13:11:48 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.