Bug 1002630 - RFE: Allow fedpkg new-sources/upload to fetch an existing URL
RFE: Allow fedpkg new-sources/upload to fetch an existing URL
Status: CLOSED DUPLICATE of bug 1048175
Product: Fedora
Classification: Fedora
Component: fedpkg (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 11:40 EDT by Richard W.M. Jones
Modified: 2014-04-16 10:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-16 10:16:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2013-08-29 11:40:20 EDT
Description of problem:

It'd be nice (and avoid a lot of time) if I could say:

  fedpkg new-sources http://example.com/foo-1.0.tar.gz

Obviously it wouldn't download and upload the file, but
would (somehow) tell the lookaside cache to fetch the file.

Note some files I have to download and then upload are routinely
10s of megabytes (especially libguestfs and Qt).

I guess fedpkg is probably the wrong component for this, but
I don't know what component the lookaside cache falls under.

Version-Release number of selected component (if applicable):

Feature not present in fedpkg-1.11-3.fc19.noarch as far
as I can tell from looking at the source / _do_curl function.
Comment 1 David Tardon 2014-04-16 10:16:13 EDT

*** This bug has been marked as a duplicate of bug 1048175 ***

Note You need to log in before you can comment on or make changes to this bug.