Bug 1002737 - initial-setup-graphical.service does not run - TypeError: Argument 1 does not allow None as a value
initial-setup-graphical.service does not run - TypeError: Argument 1 does not...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: initial-setup (Show other bugs)
20
arm Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: ARMTracker F20AlphaBlocker
  Show dependency treegraph
 
Reported: 2013-08-29 16:26 EDT by Paul Whalen
Modified: 2013-09-18 22:38 EDT (History)
5 users (show)

See Also:
Fixed In Version: anaconda-20.17-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 22:38:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Whalen 2013-08-29 16:26:31 EDT
Description of problem: 

When booting a freshly installed ARM image the system boots to a login screen rather than displaying the initial configuration. As a result, no user is created and no password set.


Version-Release number of selected component (if applicable):


How reproducible:

Everytime.

Steps to Reproduce:
1. Download a f20 alpha disk image, boot using HW or QEMU


Actual results:
System boots to a login screen. 

Expected results:
System boots to initial-setup-graphical


Additional info:

systemctl status initial-setup-graphical reports:
..
Dec 31 19:00:44 localhost.localdomain xinit[296]: self.entry_hostname.set_text(value)
Dec 31 19:00:44 localhost.localdomain xinit[296]: TypeError: Argument 1 does not allow None as a value
..
Comment 1 Kamil Páral 2013-09-04 12:59:38 EDT
Discussed at 2013-09-04 blocker review meeting [1]. This is accepted as an Alpha blocker, because it violates the following F20 alpha release criterion for ARM images with a graphical desktop: "A system installed with a release-blocking desktop must boot to a log in screen where it is possible to log in to a working desktop using a user account created during installation or a 'first boot' utility." [2]

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-09-04/
[2] https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Expected_installed_system_boot_behavior
Comment 2 Vratislav Podzimek 2013-09-05 06:31:34 EDT
Patch posted to anaconda-patches.
Comment 3 Fedora Update System 2013-09-06 18:43:16 EDT
anaconda-20.12-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.12-1.fc20
Comment 4 Fedora Update System 2013-09-07 13:03:54 EDT
Package anaconda-20.12-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.12-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16040/anaconda-20.12-1.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-09-09 20:12:06 EDT
anaconda-20.13-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.13-1.fc20
Comment 6 Fedora Update System 2013-09-10 15:49:16 EDT
anaconda-20.14-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.14-1.fc20
Comment 7 Fedora Update System 2013-09-11 21:04:16 EDT
anaconda-20.15-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.15-1.fc20
Comment 8 Paul Whalen 2013-09-12 10:38:31 EDT
This is still failing in RC2:

Sep 12 10:29:37 localhost xinit[306]: if ifcfg.get("MASTER"):
Sep 12 10:29:37 localhost xinit[306]: AttributeError: 'NoneType' object has no attribute 'get'
Comment 9 Jaroslav Reznik 2013-09-12 12:37:20 EDT
That seems like another check is missing as the initial reported one is fixed.
Comment 10 Fedora Update System 2013-09-13 21:03:52 EDT
anaconda-20.16-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.16-1.fc20
Comment 11 Fedora Update System 2013-09-14 13:45:23 EDT
Package anaconda-20.16-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.16-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16735/anaconda-20.16-1.fc20
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2013-09-16 13:46:28 EDT
anaconda-20.17-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.17-1.fc20
Comment 13 Paul Whalen 2013-09-16 15:12:42 EDT
verified fixed in anaconda-20.17-1.fc20
Comment 14 Fedora Update System 2013-09-18 22:38:49 EDT
anaconda-20.17-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.