Bug 1002749 - AIO installer fails at local host installation with 3.3rc2 packages
Summary: AIO installer fails at local host installation with 3.3rc2 packages
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-installer
Version: 3.3
Hardware: Unspecified
OS: Unspecified
urgent
unspecified
Target Milestone: ---
: ---
Assignee: Alon Bar-Lev
QA Contact:
URL:
Whiteboard: integration
Depends On:
Blocks: 918494
TreeView+ depends on / blocked
 
Reported: 2013-08-29 21:41 UTC by Jason Brooks
Modified: 2013-09-23 07:26 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-23 07:26:29 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 19025 None None None Never
oVirt gerrit 19031 None None None Never

Description Jason Brooks 2013-08-29 21:41:17 UTC
Description of problem:

On oVirt 3.3rc2 and F19, the AIO installer fails at the installing vdsm part of the process, complaining of: 
Failed to execute stage 'Closing up': 'module' object has no attribute 'SSH'

After downgrading to the 3.3rc ovirt-engine packages, the install completes as expected.

a bit more from the installer log:

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 123, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/all-in-one/vdsm.py", line 249, in _closeup
    ssh=self._ovirtsdk_xml.params.SSH(
AttributeError: 'module' object has no attribute 'SSH'
2013-08-29 17:13:31 ERROR otopi.context context._executeMethod:142 Failed to execute stage 'Closing up': 'module' object has no attribute 'SSH'



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Jason Brooks 2013-08-29 21:48:22 UTC
I actually only needed to downgrade my ovirt-engine-setup-plugin-allinone pkg for the install to succeed.

Comment 2 Jason Brooks 2013-08-30 00:11:05 UTC
Sorry for the repeated comments -- I tried to reproduce the workaround, but now I can't get AIO setup to complete at all.

Comment 3 Alon Bar-Lev 2013-08-30 06:48:52 UTC
(In reply to Jason Brooks from comment #0)

> a bit more from the installer log:
> 
> Traceback (most recent call last):
>   File "/usr/lib/python2.7/site-packages/otopi/context.py", line 123, in
> _executeMethod
>     method['method']()
>   File
> "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/all-in-one/
> vdsm.py", line 249, in _closeup
>     ssh=self._ovirtsdk_xml.params.SSH(
> AttributeError: 'module' object has no attribute 'SSH'
> 2013-08-29 17:13:31 ERROR otopi.context context._executeMethod:142 Failed to
> execute stage 'Closing up': 'module' object has no attribute 'SSH'

Ofer,

You do not have the latest engine sdk on that repo?

Michael,

Do you have rc release of the engine sdk so we can explicit depend on it?

Thanks,
Alon

Comment 4 Ofer Schreiber 2013-09-02 07:43:27 UTC
latest sdk is ovirt-engine-sdk-python-3.3.0.3-1.fc19.noarch.rpm

Comment 5 Michael Pasternak 2013-09-02 10:43:39 UTC
(In reply to Alon Bar-Lev from comment #3)
> (In reply to Jason Brooks from comment #0)
> 
> > a bit more from the installer log:
> > 
> > Traceback (most recent call last):
> >   File "/usr/lib/python2.7/site-packages/otopi/context.py", line 123, in
> > _executeMethod
> >     method['method']()
> >   File
> > "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/all-in-one/
> > vdsm.py", line 249, in _closeup
> >     ssh=self._ovirtsdk_xml.params.SSH(
> > AttributeError: 'module' object has no attribute 'SSH'
> > 2013-08-29 17:13:31 ERROR otopi.context context._executeMethod:142 Failed to
> > execute stage 'Closing up': 'module' object has no attribute 'SSH'
> 
> Ofer,
> 
> You do not have the latest engine sdk on that repo?
> 
> Michael,
> 
> Do you have rc release of the engine sdk so we can explicit depend on it?

latest is 3.3.0.5-1, new one planned to be released soon.

> 
> Thanks,
> Alon

Comment 6 Ofer Schreiber 2013-09-03 06:58:37 UTC
(In reply to Michael Pasternak from comment #5)
> (In reply to Alon Bar-Lev from comment #3)
> > (In reply to Jason Brooks from comment #0)
> > 
> > > a bit more from the installer log:
> > > 
> > > Traceback (most recent call last):
> > >   File "/usr/lib/python2.7/site-packages/otopi/context.py", line 123, in
> > > _executeMethod
> > >     method['method']()
> > >   File
> > > "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/all-in-one/
> > > vdsm.py", line 249, in _closeup
> > >     ssh=self._ovirtsdk_xml.params.SSH(
> > > AttributeError: 'module' object has no attribute 'SSH'
> > > 2013-08-29 17:13:31 ERROR otopi.context context._executeMethod:142 Failed to
> > > execute stage 'Closing up': 'module' object has no attribute 'SSH'
> > 
> > Ofer,
> > 
> > You do not have the latest engine sdk on that repo?
> > 
> > Michael,
> > 
> > Do you have rc release of the engine sdk so we can explicit depend on it?
> 
> latest is 3.3.0.5-1, new one planned to be released soon.

Can we get an official F19 and EL6 builds to be uploaded to ovirt.org?


> 
> > 
> > Thanks,
> > Alon

Comment 7 Alon Bar-Lev 2013-09-03 13:27:45 UTC
ofer, I suggest put the latest nightly in the rc repo, update spec to be >= of that version, until we have formal package.

Comment 8 Jason Brooks 2013-09-03 19:47:54 UTC
Just tested w/ ovirt-engine-sdk-python-3.3.0.5-1.20130828.gitdbe6e62.fc19.noarch.rpm from nightly and I was able to complete the AIO install. 

Didn't even have to force the rpm to install. :)

Comment 9 Mike Burns 2013-09-09 13:36:45 UTC
New builds done and uploaded, and verified by jbrooks, so marking this verified

Comment 10 Alon Bar-Lev 2013-09-09 13:39:49 UTC
Hi,

It cannot be verified without modifying dependency at spec to force pulling the new version.

What is the version you published?

Thanks!

Comment 11 Michael Pasternak 2013-09-09 13:43:31 UTC
(In reply to Alon Bar-Lev from comment #10)
> Hi,
> 
> It cannot be verified without modifying dependency at spec to force pulling
> the new version.
> 
> What is the version you published?
> 
> Thanks!

as mentioned in Comment 5, restricting to >= 3.3.0.5 is enough.

Comment 12 Mike Burns 2013-09-09 13:44:28 UTC
ovirt-engine-cli-3.3.0.4-1.fc19.x86_64
ovirt-engine-sdk-java-1.0.0.16-1.fc19.x86_64
ovirt-engine-sdk-python-3.3.0.6-1.fc19.x86_64

Comment 13 Itamar Heim 2013-09-23 07:26:29 UTC
closing as this should be in 3.3 (doing so in bulk, so may be incorrect)


Note You need to log in before you can comment on or make changes to this bug.