Bug 1002761 - Key invalidation operation needs making available, the input buffer in padd/pinstantiate isn't large enough and show doesn't handle tree depth correctly
Key invalidation operation needs making available, the input buffer in padd/p...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: keyutils (Show other bugs)
7.0
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: David Howells
Karel Srot
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 19:11 EDT by David Howells
Modified: 2014-06-18 03:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:30:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Howells 2013-08-29 19:11:36 EDT
Description of problem:

There are three problems in v1.5.5:

 (1) Key invalidation operation needs making available.

 (2) The input buffer in padd/pinstantiate isn't large enough.

 (3) keyctl show doesn't handle tree depth correctly.

These are all fixed in v1.5.6 which is now available upstream.

http://git.kernel.org/cgit/linux/kernel/git/dhowells/keyutils.git
http://people.redhat.com/~dhowells/keyutils/keyutils-1.5.6.tar.bz2
Comment 6 David Howells 2013-12-18 11:58:28 EST
I've added a test for the "keyctl show" depth problem here:

    http://git.kernel.org/cgit/linux/kernel/git/dhowells/keyutils.git/commit/?id=67e435c3f1810bc0902698ea4ac4a85b4aef7e4f

The problem was that the dumper function was counting depth in terms of characters indented by instead of keyring depth and limiting the output too much.
Comment 8 Ludek Smid 2014-06-13 05:30:30 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.