Bug 1002775 - Cannot add default route in nm-connection-editor
Cannot add default route in nm-connection-editor
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: network-manager-applet (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 20:43 EDT by Pavel Roskin
Modified: 2013-09-05 17:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-30 04:48:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 687423 None None None Never

  None (edit)
Description Pavel Roskin 2013-08-29 20:43:16 EDT
Description of problem:

It is not possible to set the default gateway in nm-connection-editor when doing manual IPv4 configuration.

Version-Release number of selected component (if applicable):
nm-connection-editor-0.9.8.2-1.fc19.i686

How reproducible:
Every time

Steps to Reproduce:
1. Run nm-connection-editor
2. Select "IPv4 Settings" tab
3. Set "Method" to manual.
4. Click "Add".
4. Enter a valid IP address, netmask and gateway (e.g. 192.168.1.23, 255.255.255.0, 0.0.0.0)
5. Click "Add" again.
6. Enter a default gateway as "route -n" would show it, e.g. IP address 0.0.0.0, netmask 0.0.0.0, gateway 192.168.1.1.

Actual results:
The "Save" button is disabled.

Expected results:
The "Save" button is enabled.  NetworkManager sets the default gateway as requested.

Additional info:
I also tried clicking the "Routes".  It presents the same table except that it has the "metric" column.  It's still impossible to save the default gateway.

The bug was reported several times.  Bug 490437 described the problem, but it was considered a duplicate of a "wider" bug 528281.  The later was fixed, but the GUI issue wasn't.  Bug 804563 mentioned the GUI issue, but the fix didn't touch the GUI.

My problem has nothing to do with VPN.  I just want my ethernet card to have two fixed IP addresses, in 192.168.1.x and 10.x.x.x ranges.  192.168.1.1 should be the default gateway.

I did it manually somehow on other systems.  But I expect that if nm-connection-editor offers such functionality as manual IPv4 configuration, it should provide such basic feature as configuring the default gateway.  It's impossible to use the internet without it.
Comment 1 Jirka Klimes 2013-08-30 04:48:15 EDT
You can't configure default route and you don't have to because NM manages it itself. You can have multiple connections active and NM sets the default route for a preferred connection automatically.
You can mark connections so that they can never be default ones.
See https://bugzilla.gnome.org/show_bug.cgi?id=687423
Comment 2 Pavel Roskin 2013-08-30 15:02:32 EDT
How do I have two connections active?  If I select "Ethernet connection 2" in nm-applet, I get disconnected from "Ethernet connection 1".  I want two addresses on the same interface without using VLAN.
Comment 3 Pavel Roskin 2013-09-05 17:56:39 EDT
I have a solution now.  The default gateway is mislabeled as simply gateway on the "IPv4 settings" tab.  So, if I want to have a default gateway, I should enter is as the gateway for the subnet it is on.

The default gateway could not be saved because nm-connection-editor assumed that I wanted to create a _local_ subnet with the address 0.0.0.0.

It is possible to have multiple addresses for the interface, which covers my needs completely.

However, it is not possible to have several Ethernet connections for one physical interface to be active at the same time.  At least the GUI doesn't allow that.

So, what we have is a bug in nm-connection-editor.  Confusing gateway and default gateway is a big deal.

Note You need to log in before you can comment on or make changes to this bug.