Bug 1002786 - SMB: ELOOP posix_compliance tests cause repeated smbd crashes
SMB: ELOOP posix_compliance tests cause repeated smbd crashes
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
2.1
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Raghavendra Talur
Jonathan Holloway
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 22:04 EDT by Jonathan Holloway
Modified: 2013-09-23 18:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:32:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Holloway 2013-08-29 22:04:13 EDT
Description of problem:
Running posix_compliance causes smbd to crash during ELOOP tests when DIST_REPLICATE volume is mounted on RHEL5.9 via cifs.

Version-Release number of selected component (if applicable):
RHS 2.1 (glusterfs 3.4.0.24rhs-1)

How reproducible:
Every time

Steps to Reproduce:
1. Create a 6x2 DIST-REP volume
2. Mount volume on client via CIFS
3. Run posix_compliance test

Actual results:
smbd crashes and posix_compliance test hangs

Expected results:
Expect smbd to not crash and posix_compliance test to complete

Additional info:
If the specific test processes are killed, posix_compliance moves on until it reaches the next ELOOP test and crash/hang repeats.

The tests hanging are:
chmod/06.t
chown/06.t
link/08.t
mkdir/08.t
mkfifo/07.t
open/12.t
rename/11.t
rmdir/05.t
symlink/07.t
truncate/07.t
unlink/07.t

Providing links to sosreports and core files
Comment 3 Vivek Agarwal 2013-08-30 07:52:13 EDT
We have some fixes going in the latest build which fix some crashes, can we test with latest build? glusterfs-3.4.0.29rhs or later
Comment 4 Jonathan Holloway 2013-08-30 14:19:56 EDT
I am also able to reproduce the problem on glusterfs-3.4.0.30rhs-2

I am not seeing the problem on glusterfs-3.4.0.20rhs-2
Comment 5 Vivek Agarwal 2013-09-05 12:53:47 EDT
We tried running this on glusterfs-3.4.0.31rhs and it passed.
Comment 6 Jonathan Holloway 2013-09-05 20:51:21 EDT
Thanks Vivek.

I ran the posix_compliance job against glusterfs-3.4.0.31rhs setup as described above and it did not hang for me either.

Changing to verified.
Comment 7 Scott Haines 2013-09-23 18:32:17 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.