Bug 1002787 - python-celery cannot be used because it has a runtime dependency on python-dateutil >= 1.5.0, which is unavailable
python-celery cannot be used because it has a runtime dependency on python-da...
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: python-celery (Show other bugs)
el6
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Andrew Colin Kissa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 22:05 EDT by Randy Barlow
Modified: 2013-10-25 13:39 EDT (History)
3 users (show)

See Also:
Fixed In Version: python-celery-2.2.8-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-25 13:39:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Barlow 2013-08-29 22:05:18 EDT
I installed python-celery-2.2.8-1.el6.noarch today, and I attempted to start a Celery worker by running celeryd. celeryd generates a Python traceback, because it has a runtime requirement on python-dateutil >= 1.5.0. Unfortunately, only python-dateutil-1.4.1-6.el6.noarch is available on my system, as provided by Red Hat. EPEL does not seem to provide the necessary newer version of python-dateutil.

The symptom is best demonstrated by simply trying to start celeryd:

$ celeryd
Traceback (most recent call last):
  File "/usr/bin/celeryd", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2659, in <module>
    parse_requirements(__requires__), Environment()
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 546, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: python-dateutil>=1.5.0,<2.0.0

In my opinion, the best solution is to provide a newer version of python-dateutil that will satisfy this dependency, and make the RPM for python-celery depend on that version.

Thanks, and let me know if you need any further information!
Comment 1 Matthias Runge 2013-10-04 08:44:07 EDT
Randy,
could you please try the following:
yum install python-dateutil15
and retry?
It looks like there is a newer version available, but not marked as requirement:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2011-3947/python-dateutil15-1.5-1.el6
If that works, I'll fix the package.
Comment 2 Randy Barlow 2013-10-04 10:26:17 EDT
Matthias,

Thanks, that does seem to work!
Comment 3 Fedora Update System 2013-10-09 13:53:16 EDT
python-celery-2.2.8-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-celery-2.2.8-2.el6
Comment 4 Fedora Update System 2013-10-10 14:35:24 EDT
Package python-celery-2.2.8-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing python-celery-2.2.8-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11807/python-celery-2.2.8-2.el6
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-10-25 13:39:59 EDT
python-celery-2.2.8-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.