Bug 1002790 - [docs] The description in the help of command "blockcopy" should be updated
[docs] The description in the help of command "blockcopy" should be updated
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Ján Tomko
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 22:28 EDT by Xuesong Zhang
Modified: 2013-11-21 04:09 EST (History)
6 users (show)

See Also:
Fixed In Version: libvirt-0.10.2-24.el6
Doc Type: Bug Fix
Doc Text:
The description of the blockcopy command in virsh help was identical to the description of the blockpull command. A correct description has been provided.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 04:09:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xuesong Zhang 2013-08-29 22:28:47 EDT
Description of problem:
The description in the help of command "blockcopy" should be updated.

Version-Release number of selected component (if applicable):
libvirt-0.10.2-23.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. check the help of virsh command blockcopy, pay attention to the description, the description is for command "blockpull", not "blockcopy".
# virsh help blockcopy
  NAME
    blockcopy - Start a block copy operation.

  SYNOPSIS
    blockcopy <domain> <path> <dest> [<bandwidth>] [--shallow] [--reuse-external] [--raw] [--wait] [--verbose] [--timeout <number>] [--pivot] [--finish] [--async]

  DESCRIPTION
    Populate a disk from its backing image.

  OPTIONS
    [--domain] <string>  domain name, id or uuid
    [--path] <string>  fully-qualified path of disk
    [--dest] <string>  path of the copy to create
    [--bandwidth] <string>  bandwidth limit in MiB/s
    --shallow        make the copy share a backing chain
    --reuse-external  reuse existing destination
    --raw            use raw destination file
    --wait           wait for job to reach mirroring phase
    --verbose        with --wait, display the progress
    --timeout <number>  with --wait, abort if copy exceeds timeout (in seconds)
    --pivot          with --wait, pivot when mirroring starts
    --finish         with --wait, quit when mirroring starts
    --async          with --wait, don't wait for cancel to finish

2. check the help of virsh command blockpull, pay attention to the description.
# virsh help blockpull
  NAME
    blockpull - Populate a disk from its backing image.

  SYNOPSIS
    blockpull <domain> <path> [<bandwidth>] [<base>] [--wait] [--verbose] [--timeout <number>] [--async]

  DESCRIPTION
    Populate a disk from its backing image.

  OPTIONS
    [--domain] <string>  domain name, id or uuid
    [--path] <string>  fully-qualified path of disk
    [--bandwidth] <string>  bandwidth limit in MiB/s
    [--base] <string>  path of backing file in chain for a partial pull
    --wait           wait for job to finish
    --verbose        with --wait, display the progress
    --timeout <number>  with --wait, abort if pull exceeds timeout (in seconds)
    --async          with --wait, don't wait for cancel to finish

3. check the help of virsh command blockcopy in rhel7, pay attention to the description.
# virsh help blockcopy
  NAME
    blockcopy - Start a block copy operation.

  SYNOPSIS
    blockcopy <domain> <path> <dest> [<bandwidth>] [--shallow] [--reuse-external] [--raw] [--wait] [--verbose] [--timeout <number>] [--pivot] [--finish] [--async]

  DESCRIPTION
    Copy a disk backing image chain to dest.

  OPTIONS
    [--domain] <string>  domain name, id or uuid
    [--path] <string>  fully-qualified path of disk
    [--dest] <string>  path of the copy to create
    [--bandwidth] <string>  bandwidth limit in MiB/s
    --shallow        make the copy share a backing chain
    --reuse-external  reuse existing destination
    --raw            use raw destination file
    --wait           wait for job to reach mirroring phase
    --verbose        with --wait, display the progress
    --timeout <number>  with --wait, abort if copy exceeds timeout (in seconds)
    --pivot          with --wait, pivot when mirroring starts
    --finish         with --wait, quit when mirroring starts
    --async          with --wait, don't wait for cancel to finish


Actual result:
In step1, the description of command blockcopy is wrong.

Expected result:
In step1, the description of command blockcopy should be same with the one in step3.
Comment 2 Alex Jia 2013-08-30 01:08:11 EDT
In POST:

commit 4faf435cbdd59ab09c69bfa47fd3c97395dca316
Author: Yanbing Du <ydu@redhat.com>
Date:   Wed Mar 27 00:46:28 2013 +0800

    virsh: Correct DESCRIPTION for virsh help blockcopy
    
    Signed-off-by: Yanbing Du <ydu@redhat.com>
Comment 6 Xuesong Zhang 2013-09-08 23:30:56 EDT
Verify this bug with build libvirt-0.10.2-24.el6, the description of the blockcopy is correct now. So change the bug status to verify.

Steps:
# virsh help blockcopy
  NAME
    blockcopy - Start a block copy operation.

  SYNOPSIS
    blockcopy <domain> <path> <dest> [<bandwidth>] [--shallow] [--reuse-external] [--raw] [--wait] [--verbose] [--timeout <number>] [--pivot] [--finish] [--async]

  DESCRIPTION
    Copy a disk backing image chain to dest.

  OPTIONS
    [--domain] <string>  domain name, id or uuid
    [--path] <string>  fully-qualified path of disk
    [--dest] <string>  path of the copy to create
    [--bandwidth] <string>  bandwidth limit in MiB/s
    --shallow        make the copy share a backing chain
    --reuse-external  reuse existing destination
    --raw            use raw destination file
    --wait           wait for job to reach mirroring phase
    --verbose        with --wait, display the progress
    --timeout <number>  with --wait, abort if copy exceeds timeout (in seconds)
    --pivot          with --wait, pivot when mirroring starts
    --finish         with --wait, quit when mirroring starts
    --async          with --wait, don't wait for cancel to finish
Comment 8 errata-xmlrpc 2013-11-21 04:09:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1581.html

Note You need to log in before you can comment on or make changes to this bug.