Bug 1002797 - [whql][netkvm]NDISTest 6.5 - [2 Machine] - AddressChange failed on each of guest
[whql][netkvm]NDISTest 6.5 - [2 Machine] - AddressChange failed on each of guest
Status: CLOSED DUPLICATE of bug 890265
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Michael S. Tsirkin
Virtualization Bugs
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 23:33 EDT by Min Deng
Modified: 2013-09-17 11:38 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-17 11:38:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
2008R2 (14.86 MB, application/zip)
2013-08-30 00:02 EDT, Min Deng
no flags Details
732 (16.62 MB, application/zip)
2013-08-30 00:12 EDT, Min Deng
no flags Details
764 (14.95 MB, application/zip)
2013-08-30 00:49 EDT, Min Deng
no flags Details
832 (19.20 MB, application/zip)
2013-08-30 00:58 EDT, Min Deng
no flags Details
864 (18.02 MB, application/zip)
2013-08-30 01:10 EDT, Min Deng
no flags Details
2012 (16.25 MB, application/zip)
2013-08-30 01:12 EDT, Min Deng
no flags Details
win2k8-32-netkvm-67-WLK (22.99 KB, image/png)
2013-09-02 04:05 EDT, guo jiang
no flags Details
CLI of win764 (1.81 KB, text/plain)
2013-09-12 06:30 EDT, Min Deng
no flags Details
DebugView-log (140.10 KB, text/x-log)
2013-09-12 06:31 EDT, Min Deng
no flags Details

  None (edit)
Description Min Deng 2013-08-29 23:33:37 EDT
Description of problem:
NDISTest 6.5 - [2 Machine] - AddressChange job failed on each of guest.
Version-Release number of selected component (if applicable):
Build 67
kernel-2.6.32-414.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.397.el6.x86_64
How reproducible:
Always
Steps to Reproduce:
1.boot up two guests and run the above jobs
2.submit the job to HCK
3.

Actual results:
The job always failed

Expected results:
The job can pass.

Additional info:
Will upload each guest cpks
Comment 1 Min Deng 2013-08-30 00:02:37 EDT
Created attachment 792006 [details]
2008R2
Comment 3 Min Deng 2013-08-30 00:12:18 EDT
Created attachment 792007 [details]
732
Comment 4 Min Deng 2013-08-30 00:49:50 EDT
Created attachment 792011 [details]
764
Comment 5 Min Deng 2013-08-30 00:58:41 EDT
Created attachment 792014 [details]
832
Comment 6 Min Deng 2013-08-30 01:10:00 EDT
Created attachment 792016 [details]
864
Comment 7 Min Deng 2013-08-30 01:12:00 EDT
Created attachment 792017 [details]
2012
Comment 8 guo jiang 2013-09-02 04:04:27 EDT
QE test "Ethernet - NDISTest 6.5" job on WLK1.6, hit the same issue on win2k8-32/64.
package version as comment #0
Comment 9 guo jiang 2013-09-02 04:05:46 EDT
Created attachment 792740 [details]
win2k8-32-netkvm-67-WLK
Comment 10 Yan Vugenfirer 2013-09-08 09:11:28 EDT
Hello,

I cannot reproduce the issue with legacy mac address setting or with control queue mac address setting in my environment.

Can you provide command line for QEMU (what's the default address that is set to adapter on both test VMs)? 

And please run DebugView http://technet.microsoft.com/en-us/sysinternals/bb896647.aspx during the test on NDISTest client VM (run as administrator and enable Capture->Capture kernel option) and attach the log to BZ.

Thanks,
Yan.
Comment 11 Min Deng 2013-09-12 05:35:05 EDT
Hi Yan,  
  The job still failed on all the guests and provide CLI about win2012 guest.
Guest 1-
/usr/libexec/qemu-kvm -M rhel6.5.0 -m 6G -smp 8,cores=8 -cpu cpu64-rhel6,+x2apic -usb -device usb-tablet -drive file=win2012-nic1.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:65:35:12:12:21,bus=pci.0,addr=0x4,id=virtio-net-pci0,ctrl_guest_offloads=on -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet2,mac=00:43:2a:52:44:13,bus=pci.0,addr=0x6 -uuid 79b5111e-4064-4d83-aba7-bd904e014406 -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win2012-nic1,server,nowait -mon chardev=111a,mode=readline -vnc :2 -vga cirrus -name win2012-nic1-69-HCK -rtc base=localtime,clock=host,driftfix=slew -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio
Guest 2-
/usr/libexec/qemu-kvm -M rhel6.5.0 -m 2G -smp 2,cores=2 -cpu cpu64-rhel6,+x2apic -usb -device usb-tablet -drive file=win2012-nic2.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:45:25:42:32:21,bus=pci.0,addr=0x4,id=virtio-net-pci0,ctrl_guest_offloads=on -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet2,mac=00:42:4a:52:24:33,bus=pci.0,addr=0x6 -uuid ab1b3a51-0720-4b41-963d-52275ea0fe5a -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win2012-nic2,server,nowait -mon chardev=111a,mode=readline -vnc :3 -vga cirrus -name win2012-nic2-69-HCK -rtc base=localtime,clock=host,driftfix=slew -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio

  Besides,as soon as I got the DebugView log I will upload it to the bug,thanks.
Best regards
Min
Comment 12 Min Deng 2013-09-12 06:30:38 EDT
Created attachment 796750 [details]
CLI of win764
Comment 13 Min Deng 2013-09-12 06:31:20 EDT
Created attachment 796751 [details]
DebugView-log
Comment 15 Mike Cao 2013-09-16 07:57:07 EDT
According to Yan ,re-assign this bug to qemu-kvm conponent 

Missing commit from upstream: 41dc8a67c7dcecdf7ae1cd25db3c46f2b42a221f

commit 41dc8a67c7dcecdf7ae1cd25db3c46f2b42a221f
Author: Michael S. Tsirkin <mst@redhat.com>
Date:   Wed Jan 16 11:37:40 2013 +0200

    virtio-net: revert mac on reset
    
    Once guest overrides virtio net primary mac,
    it retains the value set until qemu exit.
    This is inconsistent with standard nic behaviour.
    To fix, revert the mac to the original value on reset.
    
    Signed-off-by: Michael S. Tsirkin <mst@redhat.com>

diff --git a/hw/virtio-net.c b/hw/virtio-net.c
index 3bb01b1..4d80a25 100644
--- a/hw/virtio-net.c
+++ b/hw/virtio-net.c
@@ -199,6 +199,7 @@ static void virtio_net_reset(VirtIODevice *vdev)
     n->mac_table.multi_overflow = 0;
     n->mac_table.uni_overflow = 0;
     memset(n->mac_table.macs, 0, MAC_TABLE_ENTRIES * ETH_ALEN);
+    memcpy(&n->mac[0], &n->nic->conf->macaddr, sizeof(n->mac));
     memset(n->vlans, 0, MAX_VLAN >> 3);
 }
Comment 17 Yan Vugenfirer 2013-09-16 09:40:11 EDT
Related: https://bugzilla.redhat.com/show_bug.cgi?id=890265
Comment 18 Michael S. Tsirkin 2013-09-17 11:38:07 EDT

*** This bug has been marked as a duplicate of bug 890265 ***

Note You need to log in before you can comment on or make changes to this bug.