Bug 1002798 - Error when checking librepo explicit requires
Error when checking librepo explicit requires
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 23:37 EDT by Christopher Meng
Modified: 2014-09-30 19:41 EDT (History)
3 users (show)

See Also:
Fixed In Version: dnf-0.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-30 06:54:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Meng 2013-08-29 23:37:14 EDT
[root@fab SPECS]# yum install dnf -y
Loaded plugins: fastestmirror, langpacks, refresh-packagekit
Loading mirror speeds from cached hostfile
 * rawhide: mirrors.yun-idc.com
 * rpmfusion-free-rawhide: mirrors.163.com
 * rpmfusion-nonfree-rawhide: mirrors.163.com
Resolving Dependencies
--> Running transaction check
---> Package dnf.noarch 0:0.3.11-1.git7d717c7.fc20 will be installed
--> Processing Dependency: python-librepo = 0.0.5 for package: dnf-0.3.11-1.git7d717c7.fc20.noarch
--> Finished Dependency Resolution
Error: Package: dnf-0.3.11-1.git7d717c7.fc20.noarch (rawhide)
           Requires: python-librepo = 0.0.5
           Installed: python-librepo-1.0.0-1.fc21.i686 (@rawhide)
               python-librepo = 1.0.0-1.fc21
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Seems someone just push dnf update at Aug 28, so I hope you can update the deps or modify the spec.
Comment 1 Ales Kozumplik 2013-08-30 02:25:35 EDT
a new build of dnf will fix this.

Note You need to log in before you can comment on or make changes to this bug.