Bug 1002822 - Dist-geo-rep : volume won't be able to stop untill the geo-rep session is deleted.
Dist-geo-rep : volume won't be able to stop untill the geo-rep session is del...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
medium Severity medium
: ---
: RHGS 3.0.0
Assigned To: Kotresh HR
Bhaskar Bandari
:
: 992939 (view as bug list)
Depends On:
Blocks: 1049727 1170048 1176824 1179638 1186707
  Show dependency treegraph
 
Reported: 2013-08-30 01:27 EDT by Vijaykumar Koppad
Modified: 2015-05-13 12:56 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1049727 1170048 (view as bug list)
Environment:
Last Closed: 2014-09-22 15:28:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2013-08-30 01:27:14 EDT
Description of problem: Even if the geo-rep session is stopped, volume can't be stopped

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
[root@redlemon ~]# gluster v stop master
Stopping volume will make its data inaccessible. Do you want to continue? (y/n) y
volume stop: master: failed: geo-replication sessions are active for the volume 'master'.
Use 'volume geo-replication status' command for more info. Use 'force' option to ignore and stop the volume.
[root@redlemon ~]# gluster v geo stat
NODE                       MASTER    SLAVE                       HEALTH     UPTIME       
-------------------------------------------------------------------------------------
redlemon.blr.redhat.com    master    ssh://10.70.43.25::slave    Stopped    N/A          
redcloud.blr.redhat.com    master    ssh://10.70.43.25::slave    Stopped    N/A          
redmoon.blr.redhat.com     master    ssh://10.70.43.25::slave    Stopped    N/A          
redwood.blr.redhat.com     master    ssh://10.70.43.25::slave    Stopped    N/A     

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Version-Release number of selected component (if applicable):glusterfs-3.4.0.28rhs-1.el6rhs.x86_64


How reproducible:Happens everytime 


Steps to Reproduce:
1.create and start master and slave volume 
2.create and start geo-rep relationship between master and slave.
3.stop the geo-rep session master and slave 
4.try to stop the master volume. 

Actual results:It won't allow to stop the volume, until geo-rep session is deleted 


Expected results: It should allow to stop the volume, if the geo-rep is stopped. It shouldn't expect to delete the geo-rep session only. 


Additional info:
Comment 2 Kotresh HR 2014-05-19 02:12:59 EDT
This is the patch 
http://review.gluster.org/6821 which is merged.
Comment 3 Kotresh HR 2014-05-19 02:13:48 EDT
Fixed in Version: glusterfs-3.6.0.2-1
Comment 4 Kotresh HR 2014-05-20 01:33:58 EDT
*** Bug 992939 has been marked as a duplicate of this bug. ***
Comment 5 Vivek Agarwal 2014-05-26 02:15:48 EDT
Fixed as a part of the rebase, marking the bz for Denali
Comment 6 Vijaykumar Koppad 2014-06-04 05:43:31 EDT
verified on the build glusterfs-3.6.0.12-1.el6rhs.
Comment 10 errata-xmlrpc 2014-09-22 15:28:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1278.html

Note You need to log in before you can comment on or make changes to this bug.