Bug 1002832 - Change other NICs with the same configuration of IPv6 once you configured one NIC
Change other NICs with the same configuration of IPv6 once you configured one...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-30 01:46 EDT by wanghui
Modified: 2014-01-21 14:49 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-2.el6
Doc Type: Bug Fix
Doc Text:
--no tech note required
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:49:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19382 None None None Never

  None (edit)
Description wanghui 2013-08-30 01:46:36 EDT
Description of problem:
After configure one NIC with IPv6 DHCP/Auto/Disabled mode, it will changes other NICs with the same options. 

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130725.0.auto1804.el6.iso
ovirt-node-3.0.0-999.0.20130814180047git64f2554.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Clear install rhevh6.5.
2. Configure eth0 with ipv6 DHCP mode.
3. Check other NICs' configuration in TUI.
4. Configure eth0 with ipv6 auto mode.
5. Check other NICs' configuration in TUI.
6. Configure eth0 with ipv6 disabled mode.
7. Check other NICs' configuration in TUI.

Actual results:
1. After step3&5, other NICs will be changed automatically as the same configuration as the one you configuration.

Expected results:
1. The configuration in one NIC will not be cloned to others.

Additional info:
Comment 5 wanghui 2013-10-18 05:34:51 EDT
Test version:
rhev-hypervisor6-6.5-20131017.0.iso
ovirt-node-3.0.1-4.el6.noarch

Test steps:
1. Clear install rhev-hypervisor6-6.5-20131017.0.iso.
2. Configure eth0 with ipv6 DHCP mode.
3. Check other NICs' configuration in TUI.
4. Configure eth0 with ipv6 auto mode.
5. Check other NICs' configuration in TUI.
6. Configure eth0 with ipv6 disabled mode.
7. Check other NICs' configuration in TUI.
8. Configure eth0 with ipv6 static mode.
6. Check other NICs' configuration TUI.

Test results:
1. All the configuration in eth0 with IPv6 mode effects only eth0. No other NICs are configured. 

This bug is fixed in rhev-hypervisor6-6.5-20131017.0.iso. So change the bug's status from ON_QA to VERIFIED.
Comment 7 Cheryn Tan 2013-11-07 19:25:50 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 9 errata-xmlrpc 2014-01-21 14:49:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.