Bug 1002905 - ISE on .../network/systems/system_list/flex_in_channel_family.pxt?cfam_id=1048 throws RHN::Exception: DBD::Pg::st execute failed
ISE on .../network/systems/system_list/flex_in_channel_family.pxt?cfam_id=104...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
560
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Martin Korbel
: Regression
Depends On:
Blocks: 819032 sat560-blockers
  Show dependency treegraph
 
Reported: 2013-08-30 04:14 EDT by Jan Hutař
Modified: 2013-10-01 17:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: spacewalk-web-2.0.3-15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:57:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-08-30 04:14:31 EDT
Description of problem:
Accessing this perl page generates ISO.


Version-Release number of selected component (if applicable):
spacewalk-html-2.0.3-10.el6sat.noarch
spacewalk-schema-2.0.2-10.el6sat.noarch
spacewalk-postgresql-2.0.1-3.el6sat.noarch


How reproducible:
tried on one channel family only


Steps to Reproduce:
1. Have few systems consuming flex channel entitlements
2. In webUI goto:
   Overview -> Subscription Management -> Software Channel Entitlements ->
   find channel family with non-0 in "Consumed Flex Guests" column, in mine
   case I used "Red Hat Enterprise Linux (core server)"
3. Click on that non-0 number in "Consumed Flex Guests" which brings you to:
   https://<fqdn>/network/systems/system_list/flex_in_channel_family.pxt?cfam_id=1048


Actual results:
ISE on webUI. In error_log there is:
[Fri Aug 30 04:00:28 2013] [error] Execution of /var/www/html/network/systems/system_list failed at Fri Aug 30 04:00:28 2013: RHN::Exception: DBD::Pg::st execute failed: ERROR:  for SELECT DISTINCT, ORDER BY expressions must appear in select list\nLINE 12: ORDER BY UPPER(NVL(S.NAME, '(none)')), S.ID\n                  ^\n  RHN::DB /usr/share/perl5/vendor_perl/RHN/DB.pm 122 RHN::Exception::DB::throw\n  RHN::DB::st /usr/share/perl5/vendor_perl/RHN/DB.pm 456 RHN::DB::handle_error\n  RHN::DB::DataSource /usr/share/perl5/vendor_perl/RHN/DB/DataSource.pm 75 RHN::DB::st::execute_h\n  RHN::DataSource /usr/share/perl5/vendor_perl/RHN/DataSource.pm 108 RHN::DB::DataSource::run_query\n  Sniglets::ListView::List /usr/share/perl5/vendor_perl/Sniglets/ListView/List.pm 1211 RHN::DataSource::execute_query\n  Sniglets::ListView::List /usr/share/perl5/vendor_perl/Sniglets/ListView/List.pm 908 Sniglets::ListView::List::default_provider\n  Sniglets::Lists /usr/share/perl5/vendor_perl/Sniglets/Lists.pm 119 Sniglets::ListView::List::render\n  PXT::Parser /usr/share/perl5/vendor_perl/PXT/Parser.pm 160 Sniglets::Lists::listview\n  PXT::Parser /usr/share/perl5/vendor_perl/PXT/Parser.pm 72 PXT::Parser::expand_tag\n  PXT::ApacheHandler /usr/share/perl5/vendor_perl/PXT/ApacheHandler.pm 489 PXT::Parser::expand_tags\n  PXT::ApacheHandler /usr/share/perl5/vendor_perl/PXT/ApacheHandler.pm 103 PXT::ApacheHandler::pxt_parse_data\n  PXT::ApacheHandler /usr/share/perl5/vendor_perl/PXT/ApacheHandler.pm 103 (eval)\n  main -e 0 PXT::ApacheHandler::handler\n  main -e 0 (eval)
[Fri Aug 30 04:00:28 2013] [error] Traceback sent to root@localhost at /usr/share/perl5/vendor_perl/PXT/ApacheHandler.pm line 563.
[Fri Aug 30 04:00:28 2013] [error] Execution of /var/www/html/errors/500.pxt failed at Fri Aug 30 04:00:28 2013: RHN::Exception: DBD::Pg::st execute failed: ERROR:  current transaction is aborted, commands ignored until end of transaction block\n  RHN::DB /usr/share/perl5/vendor_perl/RHN/DB.pm 122 RHN::Exception::DB::throw\n  RHN::DB::User /usr/share/perl5/vendor_perl/RHN/DB/User.pm 1444 RHN::DB::handle_error\n  RHN::Access /usr/share/perl5/vendor_perl/RHN/Access.pm 71 RHN::DB::User::satellite_has_users\n  PXT::ACL /usr/share/perl5/vendor_perl/PXT/ACL.pm 93 RHN::Access::need_first_user\n  Sniglets::Navi::Node /usr/share/perl5/vendor_perl/Sniglets/Navi/Node.pm 195 PXT::ACL::eval_acl\n  Sniglets::Navi /usr/share/perl5/vendor_perl/Sniglets/Navi.pm 202 Sniglets::Navi::Node::visible\n  Sniglets::Navi /usr/share/perl5/vendor_perl/Sniglets/Navi.pm 168 Sniglets::Navi::render_nav\n  Sniglets::Navi /usr/share/perl5/vendor_perl/Sniglets/Navi.pm 128 Sniglets::Navi::format_nav\n  PXT::Parser /usr/share/perl5/vendor_perl/PXT/Parser.pm 141 Sniglets::Navi::navi_nav\n  PXT::Parser /usr/share/perl5/vendor_perl/PXT/Parser.pm 72 PXT::Parser::expand_tag\n  PXT::ApacheHandler /usr/share/perl5/vendor_perl/PXT/ApacheHandler.pm 489 PXT::Parser::expand_tags\n  PXT::Request /usr/share/perl5/vendor_perl/PXT/Request.pm 537 PXT::ApacheHandler::pxt_parse_data\n  Grail::Frame /usr/share/perl5/vendor_perl/Grail/Frame.pm 77 PXT::Request::include\n  PXT::Parser /usr/share/perl5/vendor_perl/PXT/Parser.pm 160 Grail::Frame::canvas_template_handler\n  PXT::Parser /usr/share/perl5/vendor_perl/PXT/Parser.pm 72 PXT::Parser::expand_tag\n  PXT::ApacheHandler /usr/share/perl5/vendor_perl/PXT/ApacheHandler.pm 489 PXT::Parser::expand_tags\n  PXT::ApacheHandler /usr/share/perl5/vendor_perl/PXT/ApacheHandler.pm 103 PXT::ApacheHandler::pxt_parse_data\n  PXT::ApacheHandler /usr/share/perl5/vendor_perl/PXT/ApacheHandler.pm 103 (eval)\n  main -e 0 PXT::ApacheHandler::handler\n  main -e 0 (eval)
[Fri Aug 30 04:00:29 2013] [error] Traceback sent to root@localhost at /usr/share/perl5/vendor_perl/PXT/ApacheHandler.pm line 563.


Expected results:
No ISE.


Additional info:
Tried briefly on 5.5.0 and I do not see this issue there. So this is probably a regression.
Comment 1 Tomas Lestach 2013-08-30 05:36:19 EDT
Right. This seems to be PG bug only ...

spacewalk.git: e44c2a317476172a9ff16a093c49a40f33a269cd
Comment 4 Martin Korbel 2013-09-19 06:40:21 EDT
VERIFIED on spacewalk-html-2.0.3-16.el6sat
REPRODUCED on spacewalk-web-2.0.3-10.el6sat

Steps to reproduce are in comment 0.
Comment 6 Clifford Perry 2013-10-01 17:57:19 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.