Bug 1002908 - [xfs/xfstests xfs/295] xfs_logprint: unknown log operation type (494e)
[xfs/xfstests xfs/295] xfs_logprint: unknown log operation type (494e)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xfsprogs (Show other bugs)
6.5
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Eric Sandeen
Boris Ranto
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-30 04:31 EDT by Eryu Guan
Modified: 2013-11-21 16:20 EST (History)
1 user (show)

See Also:
Fixed In Version: xfsprogs-3.1.1-14.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 16:20:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
295.full (1.83 MB, text/plain)
2013-08-30 04:31 EDT, Eryu Guan
no flags Details

  None (edit)
Description Eryu Guan 2013-08-30 04:31:12 EDT
Created attachment 792085 [details]
295.full

Description of problem:
xfstests xfs/295 fails

--- /var/lib/xfstests/tests/xfs/295.out 2013-08-20 11:47:57.000000000 +0800
+++ /var/lib/xfstests/results/xfs/295.out.bad   2013-08-30 16:12:20.792344199 +0800
@@ -1 +1,3 @@
 QA output created by 295
+xfs_logprint: unknown log operation type (494e)
+Bad data in log

Version-Release number of selected component (if applicable):
xfsprogs-3.1.1-13.el6
kernel-2.6.32-414.el6

How reproducible:
always

Steps to Reproduce:
1. check xfs/295 on xfs
2.
3.

Actual results:
test fails

Expected results:
test passes

Additional info:
Comment 1 Eryu Guan 2013-08-30 04:45:03 EDT
On one host I see different failures, maybe this is a different bug?

--- /var/lib/xfstests/tests/xfs/295.out 2013-08-22 16:14:25.000000000 +0800
+++ /var/lib/xfstests/results/xfs/295.out.bad   2013-08-30 16:40:57.748723431 +0800
@@ -1 +1,3 @@
 QA output created by 295
+Not enough headers for data length.
+Not enough headers for data length.

295.full
xfs_logprint:
    data device: 0xfd03
    log device: 0xfd03 daddr: 10486272 length: 20480

cycle: 1        version: 2              lsn: 1,0        tail_lsn: 1,0
length of Log Record: 261632    prev offset: -1         num ops: 1
uuid: 87d55ccc-a7e6-44f0-b756-50700409f976   format: little endian linux
h_size: 32768
**********************************************************************
* ERROR: for header block=0
*        not enough hdrs for data length, required num = 8, hdr num = 1
**********************************************************************
xfs_logprint:
    data device: 0xfd03
    log device: 0xfd03 daddr: 10486272 length: 20480

cycle: 1        version: 2              lsn: 1,0        tail_lsn: 1,0
length of Log Record: 261632    prev offset: -1         num ops: 1
uuid: b424c417-3b3b-4a9d-aa9b-b93e2bf79f5d   format: little endian linux
h_size: 32768
**********************************************************************
* ERROR: for header block=0
*        not enough hdrs for data length, required num = 8, hdr num = 1
**********************************************************************
Comment 2 Eric Sandeen 2013-08-30 15:00:18 EDT
hohum, that test was written to TEST the change I made in this version of xfsprogs :(

I'll look & see how this got messed up.

On the other host, does older xfsprogs work better?
Comment 3 Eric Sandeen 2013-08-30 15:08:19 EDT
Ok, in the first case I'm missing patch 2/2.  I'm sorry I didn't catch this by testing.  :(
Comment 4 Eric Sandeen 2013-08-30 16:01:38 EDT
fixed in xfsprogs-3.1.1-14
Comment 5 Eryu Guan 2013-08-31 12:03:09 EDT
(In reply to Eric Sandeen from comment #2)
> hohum, that test was written to TEST the change I made in this version of
> xfsprogs :(
> 
> I'll look & see how this got messed up.
> 
> On the other host, does older xfsprogs work better?

For the "Not enough headers for data length." issue, I retested with xfsprogs-3.1.1-10.el6 (shipped with RHEL6.4) and the result was the same.

[root@hp-dl388g8-03 xfstests]# cat /var/lib/xfstests/results/xfs/295.out.bad 
QA output created by 295
Not enough headers for data length.
Not enough headers for data length.

[root@hp-dl388g8-03 xfstests]# cat /var/lib/xfstests/results/xfs/295.full 
xfs_logprint:
    data device: 0xfd03
    log device: 0xfd03 daddr: 10486272 length: 20480

cycle: 1        version: 2              lsn: 1,0        tail_lsn: 1,0
length of Log Record: 261632    prev offset: -1         num ops: 1
uuid: 1fc529f4-734c-4b35-8701-fca7485c3a65   format: little endian linux
h_size: 32768
**********************************************************************
* ERROR: for header block=0
*        not enough hdrs for data length, required num = 8, hdr num = 1
**********************************************************************
xfs_logprint:
    data device: 0xfd03
    log device: 0xfd03 daddr: 10486272 length: 20480

cycle: 1        version: 2              lsn: 1,0        tail_lsn: 1,0
length of Log Record: 261632    prev offset: -1         num ops: 1
uuid: 0ecfbdde-8dac-48a2-b58a-60b8e393840f   format: little endian linux
h_size: 32768
**********************************************************************
* ERROR: for header block=0
*        not enough hdrs for data length, required num = 8, hdr num = 1
**********************************************************************
Comment 9 errata-xmlrpc 2013-11-21 16:20:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1657.html

Note You need to log in before you can comment on or make changes to this bug.