Bug 1002928 - ntp is removed by default
ntp is removed by default
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.13
Unspecified Unspecified
urgent Severity high (vote)
: 0.14.2
: ---
Assigned To: Amit Saha
tools-bugs
: Regression, Reopened, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-30 05:16 EDT by Petr Sklenar
Modified: 2015-07-26 18:15 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 20:46:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2013-08-30 05:16:35 EDT
Description of problem:
ntp is removed by default

Version-Release number of selected component (if applicable):
Version - 0.14.1

How reproducible:
always

Steps to Reproduce:
1. https://beaker.engineering.redhat.com/jobs/466543
see kickstart
2. there is '-ntp' in the kickstart

Actual results:
'-ntp' in the kickstart

Expected results:
do not remove ntp

Additional info:
there are more similar jobs:
F19 https://beaker.engineering.redhat.com/jobs/466543
rhel7: https://beaker.engineering.redhat.com/jobs/483862
Comment 2 Bill Peck 2013-08-30 08:53:59 EDT
Looking at the Fedora kickstart I see this:

{% if no_clock_sync is undefined %}
chrony
-ntp
{% endif %}


I'm guessing you can pass no_clock_sync=1 in ks_meta and this won't happen.

I'm not sure why ntp is removed but I do know that chrony is the default in fedora going forward.

I'll let the beaker devs comment on if we really need the -ntp in there.
Comment 3 Nick Coghlan 2013-09-01 21:43:46 EDT
The removal of ntp when enabling chrony was part of Bill's original patch (http://gerrit.beaker-project.org/#/c/1889) for bug 901670 (which ensures systems have a time daemon by default, and the chosen daemon is chrony since that's the direction Fedora is heading).

This change was released in Beaker 0.13: http://beaker-project.org/docs/whats-new/release-0.13.html#chrony-is-enabled-when-appropriate

Having chrony and ntp fighting for control of the system clock seemed unwise, so the explicit removal of ntp was never questioned during the patch review.

If our understanding is incorrect, and it's possible for chrony and ntp to coexist happily on a single system, then we could change the default behaviour.

Alternatively, if it's only a specific subset of tests that need to avoid having chrony configured, then setting 'ks_meta="no_clock_sync"' to turn off the default snippet is designed to handle that use case.
Comment 4 Bill Peck 2013-09-01 22:51:37 EDT
Sorry Nick, I couldn't remember if I had included that or not.  I should have checked git's history.
Comment 5 Nick Coghlan 2013-09-02 21:09:48 EDT
Petr, does the no_clock_sync meta variable cover your use case?

It's specifically intended to cover tasks that want to configure the NTP related packages themselves, and really don't want Beaker messing with the time related system settings.

By default, though, we need to try to ensure the clock is properly synchronised (regardless of the underlying hardware), since it avoids many other problems with multi-host testing and aligning log timestamps.
Comment 6 Petr Sklenar 2013-09-03 04:35:39 EDT
Actually we are trying to test rhel in default installation. I guess its without negative package in the kickstart. 

The biggest issue is that if we have test which need package "ntp" (written in requires) its not installed.

So is that a way to remove ntp only when there is no test which requires 'ntp' without usage of 'no_clock_sync' ? 

+ developer of ntp and chrony says that there could be both packages installed but only one can be running. So what about to switch ntp off after the installation instead of removal.
Comment 7 Nick Coghlan 2013-09-03 04:50:32 EDT
OK, sounds good - we can switch the default configuration to ensuring ntp is disabled rather than removing it entirely.

no_clock_sync will then only be needed for any tests that actually need a default NTP configuration that Beaker hasn't tinkered with, rather than all tests that happen to have a nominal dependency on the ntp package (but can tolerate having chrony running instead).
Comment 8 Amit Saha 2013-09-10 02:42:30 EDT
Discovered something else to work on. So un-assigning myself for now.
Comment 9 Amit Saha 2013-09-11 23:39:37 EDT
On Gerrit: http://gerrit.beaker-project.org/#/c/2241/
Comment 13 Nick Coghlan 2013-10-02 22:27:50 EDT
Beaker 0.15 has been released.
Comment 14 Raymond Mancy 2013-10-22 21:56:32 EDT
This change has been nominated to be back ported to the 0.14 branch, to be released as part of the next maintenance release 0.14.2.
Comment 15 Nick Coghlan 2013-10-25 02:35:52 EDT
Adjusting target milestone to make the changes backported to 0.14.2 easier to identify. 0.15.0 has enough significant regressions that it shouldn't be used, so the change means that 0.15.1 can be effectively reidentified as the union of that tag and the 0.14.2 target milestone.
Comment 18 Nick Coghlan 2013-11-06 20:46:47 EST
Closing as addressed in Beaker 0.14.2.

Note You need to log in before you can comment on or make changes to this bug.