Bug 1002940 - change in changelog-encoding
change in changelog-encoding
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ajeet Jha
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-30 05:35 EDT by Ajeet Jha
Modified: 2015-02-22 18:01 EST (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 07:46:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ajeet Jha 2013-08-30 05:35:41 EDT
Description of problem:
change in changelog-encoding doesn't use the changed encoder.

Version-Release number of selected component (if applicable):


How reproducible:
change the changelog encoding for a volume.

Steps to Reproduce:
1. gluster volume set encoding {ascii|binary}
2.
3.

Actual results:
the change in encoding ends up writing differently encoded
change in same changelog file.

Expected results:
changelog encoding of each entry in changelog file should be 
same as the encoding mentioned in header of the changelog file.

Additional info:
Comment 1 Anand Avati 2013-08-30 07:41:59 EDT
REVIEW: http://review.gluster.org/5745 (features/changelog : Improvement in changelog "encoding-change".) posted (#1) for review on master by ajeet jha (ajha@redhat.com)
Comment 2 Anand Avati 2013-09-06 07:06:01 EDT
REVIEW: http://review.gluster.org/5745 (features/changelog : Improvement in changelog "encoding-change".) posted (#2) for review on master by ajeet jha (ajha@redhat.com)
Comment 3 Anand Avati 2013-09-06 09:50:30 EDT
REVIEW: http://review.gluster.org/5844 (features/changelog : Improvement in changelog "encoding-change".) posted (#1) for review on master by ajeet jha (ajha@redhat.com)
Comment 4 Anand Avati 2013-09-12 05:38:29 EDT
REVIEW: http://review.gluster.org/5844 (features/changelog : Improvement in changelog "encoding-change".) posted (#2) for review on master by ajeet jha (ajha@redhat.com)
Comment 5 Anand Avati 2013-09-18 05:14:53 EDT
REVIEW: http://review.gluster.org/5844 (features/changelog : Improvement in changelog "encoding-change".) posted (#3) for review on master by ajeet jha (ajha@redhat.com)
Comment 6 Anand Avati 2013-09-22 05:51:47 EDT
REVIEW: http://review.gluster.org/5844 (features/changelog : Improvement in changelog "encoding-change".) posted (#4) for review on master by ajeet jha (ajha@redhat.com)
Comment 7 Anand Avati 2013-09-29 20:01:33 EDT
COMMIT: http://review.gluster.org/5844 committed in master by Anand Avati (avati@redhat.com) 
------
commit 8bd16cc88527584e91baa8773b4f01e7c44708c1
Author: ajha <ajha@redhat.com>
Date:   Fri Aug 30 15:14:46 2013 +0530

    features/changelog : Improvement in changelog "encoding-change".
    
    change in encoding method of changelog was critical section for
    "fop dispatch thread", "roll-over thread" and "reconfigure dispatch thread".
    
    In this patch the "encoding-method" is changed by the reconfigure dispatch thread
    lazily during handle_change, which solves the concurrency among the racing
    threads.
    
    BUG: 1002940
    Change-Id: I78c3e8887efa46d0fcc60755cdf4243031cfa3eb
    Signed-off-by: Ajeet Jha <ajha@redhat.com>
    Reviewed-on: http://review.gluster.org/5844
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Harshavardhana <harsha@harshavardhana.net>
Comment 8 Niels de Vos 2014-04-17 07:46:52 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.