Bug 1002942 - [RFE] anaconda does not install "environment groups"
[RFE] anaconda does not install "environment groups"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 1007523 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-30 05:44 EDT by Martin Korbel
Modified: 2014-06-09 12:04 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-21.21-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-09 12:04:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Korbel 2013-08-30 05:44:08 EDT
Description of problem:
Anaconda does not install "environment groups", but "yum grouplist" display only them + some unimportant groups.

Version-Release number of selected component (if applicable):
Fedora19

How reproducible:
100%

Steps to Reproduce:
1. Get list of groups on the Fedora 19
> yum grouplist -v 
...
Available environment groups:
   GNOME Desktop (gnome-desktop-environment)
   KDE Plasma Workspaces (kde-desktop-environment)
   Xfce Desktop (xfce-desktop-environment)
   LXDE Desktop (lxde-desktop-environment)
   Cinnamon Desktop (cinnamon-desktop-environment)
   MATE Desktop (mate-desktop-environment)
   ...
Available Groups:
   3D Printing (3d-printing)
   Administration Tools (admin-tools)
   Authoring and Publishing (authoring-and-publishing)
   ...

2. Add some environment group into kickstart
%packages
@mate-desktop-environment
%end  


Actual results:
error message in installation
group "mate-desktop-environment" does not exist

Expected results:
no errors and anaconda install all "mandatory groups" from "environment group".

Additional info:
Comment 1 David Shea 2013-09-03 10:05:56 EDT
It's worth noting that yum uses the syntax "@^mate-desktop-environment" for environment groups. Supporting this will also require a change in pykickstart.
Comment 2 David Shea 2013-09-12 13:02:04 EDT
*** Bug 1007523 has been marked as a duplicate of this bug. ***
Comment 3 L.L.Robinson 2013-12-24 15:39:24 EST
can the bug owner update this to include Fedora 20, I've just hit this with the group gnome-desktop-environment
Comment 4 Martin Korbel 2014-01-14 01:35:39 EST
I have tried it on Fedora 20 and the problem is still here.

Note You need to log in before you can comment on or make changes to this bug.