Bug 1003005 - Clone repository dialogue stays operational
Clone repository dialogue stays operational
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER5
: 6.0.0
Assigned To: Alexandre Porcelli
Zuzana Krejčová
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-30 09:05 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Summary: Various errors prevent the successful cloning of a large GIT repository. Errors include clone dialog staying open, no feedback given to the user and the ability to click the clone button several times. Cause: Consequence: Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:20:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
repo repeated in the explorer (65.95 KB, image/png)
2013-08-30 09:05 EDT, Zuzana Krejčová
no flags Details
after clicking Clone 10 times, when cloning finishes (38.23 KB, image/png)
2013-08-30 09:06 EDT, Zuzana Krejčová
no flags Details
error popup (39.75 KB, image/png)
2013-08-30 09:08 EDT, Zuzana Krejčová
no flags Details
after clicking Clone, dialogue still visible (31.48 KB, image/png)
2013-08-30 09:09 EDT, Zuzana Krejčová
no flags Details

  None (edit)
Description Zuzana Krejčová 2013-08-30 09:05:10 EDT
Created attachment 792172 [details]
repo repeated in the explorer

Description of problem:
When cloning a git repository, you are prompted by a dialogue to enter name, group, url... then click Clone. When you try to clone a not so small repository, cloning can take quite some time. In such a case, the dialogue is visible through it all and operational as well. This is quite unfortunate.

You can click Clone multiple times, which results in multiple records of the same repo appearing in the explorer. This is only a visual bug fortunately. Switching perspectives fixes these multiple records.

The whole time, while the repo is being cloned, it looks like nothing is happening. User gets absolutely no feedback.

Furthermore, once the cloning finishes, you get a popup informing you - unfortunately, it automatically switches you to the business-central tab of the browser.

You can even change the values in the dialogue and try to clone again. This seems to break it, until refresh. Though changing the repo name and and clicking Clone achieves (seemingly) successful clones.


After all of this, I found a few of these in the server log:
Exception in thread "Thread-95" org.kie.commons.java.nio.file.NoSuchFileException
 at org.kie.commons.java.nio.fs.jgit.JGitFileSystemProvider.readAttributes(JGitFileSystemProvider.java:1270)
 at org.kie.commons.java.nio.file.Files.readAttributes(Files.java:572)
 at org.kie.commons.java.nio.file.FileTreeWalker.walk(FileTreeWalker.java:52)
...

Also some
java.lang.RuntimeException: org.eclipse.jgit.errors.MissingObjectException: Missing commit 47660831ae7955b3325752202bb91947450baf7a
Caused by: org.eclipse.jgit.errors.MissingObjectException: Missing commit 47660831ae7955b3325752202bb91947450baf7a

and
org.jboss.errai.bus.client.api.base.MessageDeliveryFailure: error invoking endpoint
Caused by: java.lang.RuntimeException: org.eclipse.jgit.api.errors.ConcurrentRefUpdateException: Could not lock HEAD. RefUpdate return code was: LOCK_FAILURE


Version-Release number of selected component (if applicable):
BRMS 6.0 ER2


Steps to Reproduce:
1. Find a large git repo.
2. Got to Administration, click Repositories, Clone repository.
3. Fill in data for the large repo.
4. Keep clicking Clone.
Comment 1 Zuzana Krejčová 2013-08-30 09:06:36 EDT
Created attachment 792173 [details]
after clicking Clone 10 times, when cloning finishes
Comment 2 Zuzana Krejčová 2013-08-30 09:08:28 EDT
Created attachment 792174 [details]
error popup

I think I got this when I closed the dialogue, after I confirmed the cloning finished popup...Yes the dialogue stayed a bit longer than that.
Comment 3 Zuzana Krejčová 2013-08-30 09:09:12 EDT
Created attachment 792175 [details]
after clicking Clone, dialogue still visible
Comment 4 Alexandre Porcelli 2013-09-17 10:36:12 EDT
Fixed on UberFire  master and 0.3.x branches:

https://github.com/droolsjbpm/uberfire/commit/02f718600
https://github.com/droolsjbpm/uberfire/commit/f88cdcdb0
Comment 8 Zuzana Krejčová 2013-10-15 10:31:13 EDT
The worst parts are fixed - you cannot click clone repeatedly.

Unfortunately, apart from the Clone and Cancel buttons, the rest can be changed. Even if only changing the organizational unit has any effect, it still shouldn't be possible to change these things.
Comment 9 Alexandre Porcelli 2013-10-25 15:14:45 EDT
Issue fixed on Uberfire master and 0.3.x branches:

https://github.com/droolsjbpm/uberfire/commit/f457588f1
https://github.com/droolsjbpm/uberfire/commit/0c7c1fe5b
Comment 10 Zuzana Krejčová 2013-12-09 11:23:08 EST
Verified with ER5.

Note You need to log in before you can comment on or make changes to this bug.